Een kaart maken (QGIS3)

Vaak wil men een kaart maken die kan worden afgedrukt of gepubliceerd. QGIS heeft een krachtig gereedschap, genaamd Afdruklay-out dat u in staat stelt uw GIS-lagen te nemen en ze te verpakken om kaarten te maken.

Overzicht van de taak

De handleiding laat zien hoe een kaart van Japan kan worden gemaakt met standaard elementen voor de kaart, zoals kaart invoegen, rasters, noordpijl, schaalbalk, legenda en label.

Andere vaardigheden die u zult leren

  • Hoe de QGIS projectvariabelen te bekijken en te wijzigen

  • Hoe expressies van QGIS te gebruiken

De gegevens ophalen

We zullen een gegevensset van Natural Earth gebruiken - specifiek de Natural Earth Quick Start Kit die prachtig opgemaakte globale lagen bevat die direct in QGIS kunnen worden geladen.

Download de Natural Earth Quickstart Kit.

Gegevensbron [NATURALEARTH]

Procedure

  1. Download en pak de gegevens van de Natural Earth Quick Start Kit uit. Open QGIS. Zoek naar de map Natural Earth quick start in het paneel Browser. Vergroot de map om het project Natural_Earth_quick_start_for_QGIS_v3 te zoeken. Dat is het projectbestand dat opgemaakte lagen in de indeling QGIS Document bevat. Dubbelklik op het project om het te openen.

../../_images/159.png
  1. Het zal u opvallen dat de kaart de labels in het Grieks heeft. Dit project gebruikt variabelen om de taal in te stellen. We kunnen de variabelen wijzigen door te gaan naar Project ‣ Eigenschappen.

../../_images/230.png

Notitie

Projectvariabelen zijn een fantastische manier om projectspecifieke waarden op te slaan om overal te kunnen gebruiken waar u een expressie in QGIS kunt gebruiken. Het project Natural_Earth_quick_start_for_QGIS_v3 komt met veel vooringestelde variabelen die worden gebruikt voor opmaak in dat project.

  1. Schakel naar de tab Variabelen in het dialoogvenster Projecteigenschappen. Zoek naar de variabele project_language en klik op de kolom Waarde om die te bewerken. Wijzig de taal naar name_en en klik op OK.

../../_images/325.png
  1. Klik, terug in het hoofdvenster van QGIS, op de knop Bijwerken in de werkbalk Kaartnavigatie. U zult de kaart nu gerenderd zien worden met Engelse lanels.

../../_images/412.png
  1. Gebruik de gereedschappen voor verschuiven en zoomen op de werkbalk Kaartnavigatie en zoom naar Japan.

../../_images/512.png
  1. U kunt enkele kaartlagen voor gegevens die we niet nodig hebben voor deze kaart uitschakelen. Vergroot de map z5 - 1:18m en deselecteer het vak naast de lagen ne_10m_geography_marine_polys en ne_10m_admin_0_disputed_areas. We moeten een toepasselijke projectie kiezen voor we een kaart geschikt maken voor afdrukken. Het standaard CRS voor het project is ingesteld op EPSG:3857 Pseudo-Mercator. Dit is een CRS dat populair wordt gebruikt voor webkaarten en een goede keuze is voor ons doel, dus kunnen we het laten staan op zijn standaard waarde. Ga naar Project ‣ Nieuwe afdruklay-out.

../../_images/612.png

Notitie

Voor Japan is Japan Plane Rectangular CS een geprojecteerd coördinaten referentiesysteem (CRS) dat ontworpen is voor minimale vervormingen. Het is opgedeeld in 18 zones en als u werkt met een kleinere regio in Japan, is het gebruiken van dit CRS beter.

  1. U zult worden gevraagd een titel voor de afdruklay-out in te vullen. U mag die leeg laten en klik op OK.

../../_images/711.png

Notitie

Leeg laten van de naam van de printvormgeving zal een standaard naam, zoals Lay-out 1, toewijzen.

  1. Klik, in het venster Afdruklay-out, op Zoom naar 100% om de volledige inhoud van de lay-out weer te geven.

../../_images/811.png
  1. Nu zouden we de kaartweergave die we zien in het kaartvenster van QGIS moeten overbrengen naar de lay-out. Ga naar Item toevoegen ‣ Kaart toevoegen.

../../_images/911.png
  1. Als de modus Kaart toevoegen actief is, houdt dan de linker muisknop ingedrukt en sleep een rechthoek waar u de kaart wilt invoegen.

../../_images/1011.png
  1. U zult zien dat het rechthoekige venster zal worden gerenderd met de kaart uit het kaartvenster van QGIS. De gerenderde kaart zou niet het gehele gebied van onze interesse kunnen bedekken. Gebruik de opties Bewerken ‣ Item selecteren/verplaatsen en Lay-out ‣ Inhoud verschuiven om de kaart in het venster te verschuiven en het in de lay-out te centreren.

../../_images/1115.png
  1. Laten we het zoomniveau voor de kaart aanpassen. Klik op de tab Item-eigenschappen en voer 10000000 in als waarde voor Schaal.

../../_images/1212.png
  1. Nu zullen we een kaartdetail toevoegen dat een ingezoomde weergave van het gebied rondom Tokio weergeeft. Selecteer, vóór we wijzigingen maken in het hoofdvenster van QGIS, de vakken Lagen vergrendelen en Stijlen voor lagen vergrendelen. Dat zal er voor zorgen dat als we enkele lagen uitschakelen of hun stijlen wijzigen, deze weergave niet zal wijzigen.

../../_images/1312.png
  1. Schakel naar het hoofdvenster van QGIS. Schakel de groep lagen z5 - 1:18m uit en activeer de groep z7 - 1: 4m. Deze groep lagen heeft een opmaak die meer toepasselijk is voor een ingezoomde weergave. Gebruik de gereedschappen voor verschuiven en zoomen op de werkbalk Kaartnavigatie en zoom naar de omgeving Tokio.

../../_images/1410.png
  1. We zijn nu klaar om het kaartdetail in te voegen. Schakel naar het venster Afdruklay-out. Ga naar Item toevoegen ‣ Kaart toevoegen.

../../_images/1510.png
  1. Sleep een rechthoek op de plaats waar u het kaartdetail wilt plaatsen. U zult nu zien dat we 2 kaartobjecten in de afdruklay-out hebben. Zorg ervoor, bij het maken van wijzigingen, dat u de juiste kaart hebt geselecteerd.

../../_images/168.png
  1. Selecteer het object Kaart 2 dat we zojuist hebben toegevoegd uit het paneel Items. Selecteer de tab Item-eigenschappen. Scroll naar beneden naar het paneel Frame en selecteer het vak ernaast. U kunt de kleur en dikte van de rand van het frame wijzigen zodat het eenvoudig te onderscheiden is van de achtergrond van de kaart.

../../_images/179.png
  1. Een handige mogelijkheid van afdruklay-out is dat het automatisch het gebied van de hoofdkaart, dat wordt weergegeven in ons kaartdetail, kan accentueren. Selecteer het object Kaart 1 uit het paneel Items. Scroll, op de tab Item-eigenschappen, naar beneden tot het gedeelte Overzichtskaarten. Klik op de knop Een nieuw overzicht toevoegen.

../../_images/188.png
  1. Selecteer Kaart 2 als het Kaartframe. Wat dit aan de afdruklay-out doorgeeft is dat het ons huidige object Kaart 1 moet accentueren met het bereik van de kaart die wordt weergegeven in het object Kaart 2.

../../_images/197.png
  1. Nu we het kaartdetail gereed hebben, zullen we een raster aan de hoofdkaart toevoegen. Selecteer het object Map 1 uit het paneel Items. Scroll, op de tab Item-eigenschappen, naar beneden naar het gedeelte Rasters. Klik op de knop Voeg een nieuw raster toe, gevolgd door Raster aanpassen….

../../_images/206.png
  1. Standaard hebben de rasterlijnen dezelfde eenheden en projecties als de huidige geselecteerde kaartprojecties. Het is echter meer algemeen en handiger om de rasterlijnen in graden weer te geven. We kunnen een ander CRS selecteren voor het raster. Klik op de knop Wijzigen… naast CRS.

../../_images/2112.png
  1. Voer, in het dialoogvenster Keuze Coördinaten ReferentieSysteem, 4326 in in het vak Filter. Selecteer uit de resultaten WGS84 EPSG:4326 als het CRS. Klik op OK.

../../_images/2210.png
  1. Selecteer de waarden Interval als 5 graden in beide richtingen X en Y. U kunt de Verspringing aanpassen om te wijzigen waar de rasterlijnen verschijnen.

../../_images/235.png
  1. Scroll naar beneden naar het gedeelte Frame en selecteer het vak Coördinaten tekenen. De standaard indeling is Decimalen maar het verschijnt als een getal. We kunnen het aanpassen om een synmbool ° toe te voegen. Kies Aangepast en klik op de knop Expressie ernaast.

../../_images/245.png
  1. Voer de volgende expressie in om een tekenreeks te maken dat het getal van het raster neemt en daar een symbool ° aan toevoegt.

concat(to_string(@grid_number), '°    ')
../../_images/254.png
  1. Merk nu op dat de rasters een aangepast label hebben vanuit de expressie. Pas de instellingen voor de positie aan voor Links, Rechts, Boven en Onder zoals u dat wilt.

../../_images/264.png
  1. Nu zullen we een rechthoekig frame toevoegen dat andere kaartelementen, zoals noordpijl, schaalbalk en label, zal bevatten. Ga naar Item toevoegen ‣ Vorm toevoegen ‣ Rechthoek toevoegen.

../../_images/274.png
  1. U kunt de Stijl van de rechthoek wijzigen zodat die overeenkomt met de achtergground.

../../_images/284.png
  1. Nu zullen we een noordpijl aan de kaart toevoegen. QGIS bevat een aardige collectie kaartgerelateerde afbeeldingen - inclusief vele typen noordpijlen. Klik op Item toevoegen ‣ Afbeelding toevoegen.

../../_images/293.png
  1. Teken, met de linker muisknop ingedrukt, een rechthoek. Klik, in het paneel aan de rechterkant, op de tab Item-eigenschappen en vergroot het gedeelte Mappen doorzoeken en selecteer de afbeelding die u wilt.

../../_images/303.png
  1. Nu zullen we een schaalbalk toevoegen. Klik op Item toevoegen ‣ Schaalbalk toevoegen.

../../_images/3110.png
  1. Klik in de lay-out waar u de schaalbalk wilt laten verschijnen. Zorg er voor dat u, op de tab Item-eigenschappen, het juiste kaartelement Kaart 1 hebt gekozen dat de schaalbalk moet weergeven. Kies de stijl die aan uw eisen voldoet. Wijzig in het paneel Segmenten, de Vaste grootte naar 200 eenheden en pas de segmenten naar uw wensen aan.

../../_images/326.png
  1. Nu is het tijd om onze kaart te labelen. Klik op Item toevoegen ‣ Label toevoegen.

../../_images/331.png
  1. Klik op de kaart en teken een vak waar het label zouten staan. Vergroot, in de tab Item-eigenschappen, het gedeelte Label en voer een label voor de kaart in. Voeg op soortgelijke wijze labels toe voor auteursrechten voor software en gegevens.

../../_images/341.png
  1. Als u eenmaal tevreden bent met de kaart, kunt u die exporteren als een afbeelding, PDF of SVG. Laten we het voor deze handleiding exporteren als een afbeelding. Klik op Lay-out ‣ Als afbeelding exporteren.

../../_images/351.png
  1. Sla de afbeelding op in de indeling van uw voorkeur. Hieronder staat de geëxporteerde PNG-afbeelding.

../../_images/output.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License