Analiza storitvenih območij z uporabo storitve Openrouteservice (QGIS3)

Analiza storitvenega območja je koristna pri ocenjevanju dostopnosti lokacij. Glede na lokacije gasilskih postaj, bolnišnic, postaj javnega prevoza, itd., lahko s takšno analizo ugotovite, katera območja je mogoče oskrbovati s teh lokacij glede na prevoženo razdaljo ali čas. Do nedavnega je bilo tako analizo težko opraviti z uporabo odprtokodnih orodij in podatkov. Zdaj pa imamo dostop do globalnega omrežja ulic z uporabo OpenStreetMap (OSM) in brezplačnih spletnih storitev, kot je Openrouteservice (ORS), ki lahko izvajajo kompleksne naloge usmerjanja z uporabo podatkov OpenStreetMap (OSM). V tej vadnici bomo uporabili vtičnik ORS Tools Plugin za izvajanje analize storitvenih območij v QGISu.

Pregled naloge

Uporabili bomo podatke o postajah podzemne železnice v indijskem mestu Kochi, z namenom določitve območij, ki so oddaljena do 15 minut hoje.

Druga znanja, ki jih boste pridobili

  • Kako v QGIS naložiti podatke o tranzitu iz Splošne specifikacije za tranzitni vir (GTFS).

  • Kako pretvoriti zaporedne podatke o točkah v linijske sledi z orodjem Points to Path.

Pridobivanje podatkov

Kochi Metro Rail Limited (KMRL) zagotavlja odprte podatke za projekt Kochi Metro Rail v formatu Global Transit Feed Specification (GTFS-static). Zahtevek za prenos podatkov pošljite na strani Open Data.

Zaradi priročnosti lahko kopijo zbirk podatkov neposredno prenesete s spodnjih povezav:

KMRL-Open-Data.zip

Vir podatkov [KMRL]

Nastavitve

Openrouteservice API zagotavlja algoritme za usmerjanje, ki delujejo na brezplačnih geografskih podatkih iz OpenStreetMap. Gre za brezplačno spletno storitev, do katere je mogoče dostopati prek vtičnika QGIS. Čeprav je storitev brezplačna, se je treba prijaviti in pridobiti ključ API. Ključ API se uporablja za preprečevanje zlorab in uveljavljanje omejitev uporabe.

  1. Obiščite Openrouteservice Sign Up stran in ustvarite račun. Ko je račun aktiviran, obiščite svojo Prikazno ploščo in podajte zahtevo. Izberite Free kot Token type in vnesite ORS Tools QGIS kot Token name. Kliknite CREATE TOKEN.

../../_images/setup12.png
  1. Ko ga ustvarite, kopirajte dolg niz, prikazan pod Key. To je edinstven identifikator, povezan z vašim računom, ki se bo uporabljal za avtorizacijo uporabe te storitve.

../../_images/setup21.png
  1. Odprite QGIS. Obiščite Plugins ‣ Manage and Install plugins. Poiščite vtičnik ORS Tools in ga namestite. Kliknite Close.

../../_images/setup3.png
  1. V glavnem oknu QGIS pojdite na Web ‣ ORS Tools ‣ Provider Settings.

../../_images/setup4.png
  1. Razširite razdelek openrouteservice in v besedilno polje API Key prilepite key (kopiran v koraku 2). Kliknite OK.

../../_images/setup5.png

Postopek

  1. Unzip the downloaded KMRL-Open-Data.zip file to a folder on your computer. You will notice that the unzipped directory contains many text files. Each file contains data for a different aspect of the transit system. The format of the files and their uses are described in GTFS Reference. Out of all the files, 2 files contain geospatial data and are of interest to us. The file shapes.txt contains points that describe a physical path that the vehicle takes, and the file stops.txt contains the location of each transit stop. Both of these are CSV files that can be imported into QGIS. Click the Open Data Source Manager button.

../../_images/1145.png
  1. V pogovornem oknu Data Source Manager preklopite na zavihek Delimited Text. Kliknite gumb poleg File name in poiščite datoteko shapes.txt. Izberite CSV (comma separated values) kot File Format. Polji X in Y morata biti samodejno izpolnjeni. Kliknite Add.

../../_images/2123.png
  1. Ponovite, ponovno kliknite gumb in izberite datoteko stops.txt. Kliknite Add. Kliknite Close.

../../_images/365.png
  1. Med Layers bosta dodana dva nova sloja stops in shapes. Pretvorimo sloj točk shapes v sloj črt, ki predstavlja pot linije podzemne železnice. Pojdite na Processing ‣ Toolbox.

../../_images/434.png
  1. Poiščite in poiščite orodje Vector creation ‣ Points to path. Z dvoklikom ga zaženite.

../../_images/530.png
  1. V pogovornem oknu Points to Path izberite shapes kot Input point layer. V skladu s specifikacijami GTFS ima vsaka posamezna pot edinstven shape_id, zato ga izberite v spustnem meniju kot Path group expression. Določimo lahko tudi vrstni red točk, ki bodo tvorile linijo, tako da izberemo shape_pt_sequence kot Order expression. Kliknite Run.

../../_images/629.png
  1. Med Layers bo dodan nov sloj Paths. Izklopite lahko vidnost sloja shapes, da vidite novo dodani sloj črt.

../../_images/729.png
  1. Ko smo dodali podatke o postajah in linijah podzemne železnice, lahko začnemo z analizo omrežja. V Processing Toolbox poiščite orodje ORS Tools ‣ Isochrones ‣ Isochrones From Layer. Z dvoklikom ga zaženite.

../../_images/828.png
  1. Izberite openrouteservice kot Provider. Izračunali bomo poligon 15-minutne razdalje hoje od vsake postaje podzemne železnice. Izberite stops kot Input Point Layer. Izberite stop_id kot Input Layer ID Field. Iz spustnega seznama Travel mode izberite foot-walking. Ker nas zanima območje, ki temelji na času, kot polje Dimension izberite time. Nazadnje kot Ranges vnesite 15 minut. Kliknite Run.

../../_images/929.png

Opomba

Upoštevajte, da je za API storitve Openrouteservice omejitev 20 zahtevkov na minuto za izohrone. Če ima vaš sloj več kot 20 točk, se lahko prikažejo napake, ki kažejo, da je omejitev hitrosti presežena. Orodje lahko uporabljate naprej in bo še naprej obdelovalo 20 točk na minuto.

  1. Ko orodje konča, se med Layers naloži nov sloj``Isochrones``. Vsaka točka ima povezan poligon, ki predstavlja območje, ki je dostopno v 15 minutah hoje. Da bi si to ogledali v kontekstu podatkov, ki so bili uporabljeni za njihovo ustvarjanje, lahko dodamo osnovni zemljevid OpenStreetMap. Pomaknite se navzdol po plošči Browser in poiščite XYZ Tiles ‣ OpenStreetMap. Povlecite jo na delovno površino.

../../_images/1035.png
  1. Med Layers bo dodan nov sloj OpenStreetMap. Povlecite ga navzdol, da spremenite vrstni red slojev in ga ohranite na dnu skladovnice slojev. Povečajte in pomaknite, da preverite, ali se rezultati ujemajo s cestnim omrežjem. Videli boste, da poligoni niso krožni, saj se potovalni čas izračunava vzdolž cest, zato imajo območja brez cest manjšo površino.

../../_images/1146.png
  1. Za izračun storitvenih območij moramo opraviti še zadnjo nalogo. Posamezne izohrone lahko združimo v en sam poligon, ki predstavlja dostopna območja. Poiščite in poiščite Vector geometry ‣ Dissolve.

../../_images/1238.png
  1. Izberite Isochrones kot Input layer in kliknite Run.

../../_images/1336.png
  1. Ko se obdelava konča, se med Layers doda nova plast Dissolved. Ta poligon predstavlja celotno območje, ki je dostopno iz sistema podzemne železnice v 15 minutah hoje.

../../_images/1432.png

Opomba

To je preprost primer, kako je mogoče v QGIS-u opraviti analizo storitvenih območij za projekt javnega prevoza. Celovitejša analiza storitvenih območij za sistem podzemne železnice bi vključevala tudi druge vrste prevoza. Za razširitev analize bi lahko vključili napajalne avtobuse, bližnja avtobusna postajališča in proge, ki oskrbujejo ta postajališča. Vključili bi lahko tudi potovanja z drugimi načini prevoza, kot npr. avtomobil in taksi.


If you want to give feedback or share your experience with this tutorial, please comment below. (requires GitHub account)