Digitalizar Datos del Mapa

La digitalización es una de las tareas más comunes que un Especialista SIG tiene que hacer. A menudo una gran cantidad de tiempo SIG es utilizado en digitalizar datos ráster para crear capas vector que utiliza en su análisis. QGIS tiene capacidades poderosas de digitalización en pantalla y edición que exploraremos en este tutorial.

Vista general de la tarea

Usaremos un mapa topográfico ráster y crearemos varias capas ráster que representan entidades alrededor de un parque.

Otras habilidades que aprenderás

  • Construir pirámides para grandes conjuntos de datos ráster para acelerar las operaciones de acercamiento y desplazamiento.

  • Trabajar con una base de datos Spatialite.

Obtener los datos

Land Information New Zealand (LINZ) provee mapas topográficos ráster a escala 1:50.000 para la masa de tierra principal de Nueva Zelanda y las Islas Chatham.

Descargue el Archivo de Imagen geoTIFF de la página de descarga del mapa Christchurch Topo50.

Para su comodidad, puede descargar directamente una copia del conjunto de datos del siguiente enlace:

BX24_GeoTifv1-02-clip.tif

Fuente de Datos [LINZ]

Procedmiento

  1. Vaya a Capa ‣ Agregar Capa Ráster. Localice el BX24_GeoTifv1-02.tif descargado y clic en Abrir.

../_images/1153.png
  1. Este es un archivo ráster grande y podría notar que cuando se acerca o desplaza alrededor del mapa, toma un poco de tiempo para que el mapa sea representado como imagen. QGIS ofrece una solución simple para hacer que los rásters cargue mucho más rápido usando Pirámides de Imagen. QGIS crea teselas pre-representadas a diferentes resoluciones y estas le son presentadas en vez del ráster completo. Esto hace que la navegación del mapa sea rápida y responda rápido. Clic-derecho a la capa BX24_GeoTifv1-02 y elija Propiedades.

../_images/2106.png
  1. Elija la pestaña Pirámides. Presione la tecla Ctrl y seleccione todas las resoluciones ofrecidas en el panel Resoluciones. De las otras opciones predeterminadas y clic en Construir Pirámides. Una vez que finalice el proceso, clic en Aceptar.

../_images/358.png
  1. De vuelta en la ventana QGIS principal, use la herramienta Acercamiento para localizar el área Hagley Park en Christchurch. Este es el parque que estaremos digitalizando.

../_images/440.png
  1. Antes de comenzar, necesitamos establecer las Opciones de Digitalización predeterminadas. Vaya a Configuración ‣ Opciones....

../_images/540.png
  1. Seleccione la pestaña Digitalización en el diálogo Opciones. Defina el Modo de autoajuste predeterminado a A vértice y segmento. Esto le permitirá autoajustar al vértice o segmento de línea más cercanos. También prefiero establecer la Tolerancia predeterminada de autoajuste y Radio de búsqueda para ediciones de vértice en píxeles en vez de unidades de mapa. Esto asegurará que la distancia de autoajuste permanece constante sin importar el nivel de acercamiento. Dependiendo de su resolución de pantalla de computadora, podría elegir un valor apropiado. Clic en Aceptar.

../_images/638.png
  1. Ahora estamos listos para comenzar la digitalización. Primero crearemos una capa de caminos y digitalizaremos los caminos alrededor del área de parque. Seleccione Capa ‣ Nuevo ‣ Nueva Capa Spatialite.... También puede elegir crear una Nueva capa de Archivo Shape... en vez si lo prefiere. Spatialite es un formato abierto de base de datos similar al formato geodatabase de ESRI. La base de datos Spatialite está contenida dentro de un solo archivo en su disco duro y puede contener diferentes tipos de capas espaciales (punto, línea, polígono) así como no-espaciales. Esto facilita mucho el desplazamiento en vez de un montón de archivos shape. En este tutorial, crearemos un par de capas polígono y una capa línea, por lo que una base de datos Spatialite es más apropiada. Usted puede siempre cargar una capa spatialite y guardarla como un archivo shape o cualquier otro formato que quiera.

../_images/738.png
  1. En el diálogo Nueva Capa Spatialite, clic en el botón ... y guarde una nueva base de datos con nombre nztopo.sqlite. Elija el Nombre de capa como Roads y seleccione Line para el Tipo. El mapa base topográfico está en el SRC EPSG:2193 - NZGD 2000, por lo que seleccionaremos lo mismo para nuestra capa de caminos. Marque la caja Crear una llave primaria de autoincremento. Esto creará un campo llamado pkuid en la tabla de atributos y asignará un id numérico único automáticamente para cada entidad. Cuando cree una capa SIG, debe decidir que atributos tendrá cada entidad. Debido a que es una capa de caminos, tendremos 2 atributos básicos - Nombre y Clase. Ingrese Name en el Nombre del atributo en la sección Nuevo atributo y clic en Agregar a la lista de atributos.

../_images/837.png
  1. De la misma manera cree un nuevo atributo Class del tipo Dato texto. Clic en Aceptar.

../_images/938.png
  1. Once the layer is loaded, click the Toggle Editing button to put the layer in editing mode.
../_images/1036.png
  1. Click the Add feature button. Click on the map canvas to add a new vertex. Add new vertices along the road feature. Once you have digitized a road segment, right-click to end the feature.

Nota

You can use the scroll wheel of the mouse to zoom in or out while digitizing. You can also hold the scroll button and move the mouse to pan around.

../_images/1154.png
  1. After you right-click to end the feature, you will get a pop-up dialog called Attributes. Here you can enter attributes of the newly created feature. Since the pkuid is an auto-incrementing field, you will not be able to enter a value manually. Leave it blank and enter the road name as it appears on the topo map. Optionally, assign a Road Class value as well. Click OK.
../_images/1237.png
  1. The default style of the new line layer is a thin line. Let’s change it so we can better see the digitized features on the canvas. Right click the Roads layer and select Properties.
../_images/1336.png
  1. Select the Style tab in the Layer Properties dialog. Choose a thicker line style such as Primary from the predefined styles. Click OK.
../_images/1435.png
  1. Now you will see the digitized road feature clearly. Click Save Layer Edits to commit the new feature to disk.
../_images/1534.png
  1. Before we digitize remaining roads, it is important to update some other settings that are important to create an error free layer. Go to Settings ‣ Snapping Options....
../_images/1630.png
  1. In the Snapping Options dialog, check the Enable topological editing. This option will ensure that the common boundaries are maintained correctly in polygon layers. Also check the Enable snapping on intersection which allows you to snap on an intersection of a background layer.
../_images/1728.png
  1. Now you can click Add feature button and digitize other roads around the park. Make sure to click Save Edits after you add a new feaure to save your work. A useful tool to help you with digitizing is the Node Tool. Click the Node Tool button.
../_images/1828.png
  1. Once the node tool is activated, click on any feature to show the vertices. Click on any vertex to select it. The vertex will change the color once it is selected. Now you can click and drag your mouse to move the vertex. This is useful when you want to make adjustments after the feature is created. You can also delete a selected vertex by clicking the Delete key. (Option+Delete on a mac)
../_images/1922.png
  1. Once you have finished digitizing all the roads, click the Toggle Editing button.
../_images/2016.png
  1. Now we will create a polygon layer representing the park boundaries. Go to Layer ‣ New ‣ New Spatialite Layer.... Select the nztopo.sqlite database from the dropdown list. Name the new layer as Parks. Select Polygon as the Type. Create a new attribute called Name. Click OK.
../_images/2121.png
  1. Click the Add feature button and click on the map canvas to add a polygon vertex. Digitize the polygon representing the park. Make sure you snap to the roads vertices so there are no gaps between the park polygons and road lines. Right-click to finish the polygon.
../_images/2219.png
  1. Enter the park name in the Attributes pop-up.
../_images/2316.png
  1. Polygon layers offer another very useful setting called Avoid intersections of new polygons. Go to Settings ‣ Snapping Options.... Check the box in the Avoid Int column in the row for the Parks layer. Click OK.
../_images/2415.png
  1. Now click on Add feature to add a polygon. With the Avoid intersections of new polygons, you will be able quickly digitize a new polygon without worrying about snapping exactly to the neighboring polygons.
../_images/2514.png
  1. Right-click to finish the polygon and enter the attributes. Magically the new polygon is shrunk and snapped exactly to the boundary of the neighboring polygons! This is very useful when digitizing complex boundaries where you need not be very precise and still have topologically correct polygon. Click Toggle Editing to finish editing the Parks layer.
../_images/2612.png
  1. Now it is time to digitize a buildings layer. Create a new polygon layer named Buildings by going to Layer ‣ New ‣ New Spatialite Layer.
../_images/2712.png
  1. Once the Buildings layer is added, turn off the Parks and Roads layer so the base topo map is visible. Select the Buildings layer and click Toggle Editing.
../_images/2612.png
  1. Digitizing buildings can be a cumbersome task. Also it is difficult to add vertices manually so that the edges are perpendicular and form a rectangle. We will use a plugin called Rectangles Ovals Digitizing to help with this task. See Uso de complementos to see how to search and install plugins. Once the Rectangles Ovals Digitizing plugin is installed, you will see a new toolbar appear above the canvas.
../_images/2910.png
  1. Zoom to an area with the buildings and click Rectangle by Extent button. Click and drag the mouse to draw a perfect rectangle. Similarly, add remaining buildings.
../_images/305.png
  1. You will notice that some buildings are not vertical. We will need to draw a rectangle at an angle to match the building footprint. Click the Rectangle from center.
../_images/3112.png
  1. Click at the center of the building and drag the mouse to draw a vertical rectangle.
../_images/3211.png
  1. We need to rotate this rectangle to match the image on the topo map. The rotate tool is available in the Advanced Digitizing toolbar. Right-click on an empty area on the toolbar section and enable the Advanced Digitizing toolbar.
../_images/3311.png
  1. Click the Rotate Feature(s) button.
../_images/3410.png
  1. Use the Select Single feature tool to select the polygon that you want to rotate. Once the Rotate Feature(s) tool is activated, you will see crosshairs at the center of the polygon. Click exactly on that crosshairs and drag the mouse while holding the left-click button. A preview of the rotated feature will appear. Let go of the mouse button when the polygon aligns with the building footprint.
../_images/359.png
  1. Save the layer edits and click Toggle Editing once you finish digitizing all buildings. You can drag the layers to change their order of appearance.
../_images/361.png
  1. The digitizing task is now complete. You can play with the styling and labelling options in layer properties to create a nice looking map from the data you created.
../_images/371.png
If you liked tutorials on this site and do check out spatialthoughts.com for more free resources.
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License