Trabajar con Proyecciones (QGIS3)

Proyecciones de mapa - o Sistema de Referencia de Coordenadas (SRC) - a menudo causan bastante frustración cuando se trabaja con datos SIG. Pero una comprensión apropiada de los conceptos y el acceso a las herramientas correctas harán mucho más fácil el tratar con proyecciones. En este tutorial, exploraremos cómo trabajan las proyecciones en QGIS y aprenderemos acerca de herramientas disponibles para capas de datos vectoriales y ráster.

Vista general de la tarea

La tarea es reproyectar los objetos espaciales seleccionados y superponer capas de datos en diferentes proyecciones en QGIS.

Obtener los datos

Natural Earth tiene un conjunto de datos Admin 0 - Países. Descargue los países

El Ordnance Survey del Reino Unido provee datos abiertos para descargar. Descargue el Producto MiniScale ráster para Gran Bretaña y extráigalo a una carpeta en su computadora.

Para su comodidad, puede descargar directamente una copia del conjuntos de datos del enlace de abajo:

ne_10m_admin_0_countries.zip

minisc_gb.zip (Contiene solo los archivos requeridos para este tutorial)

Fuente de datos: [NATURALEARTH] [OSOPENDATA]

Procedimiento

  1. Abra QGIS. Vaya a Capas ‣ Añadir capa ‣ Añadir capa vectorial….

../../_images/1142.png
  1. Clic en junto a Fuente, busque el archivo descargado ne_10m_admin_0_countries.shp y clic en Añadir.

../../_images/2104.png
  1. Abajo en la ventana QGIS, notará la etiqueta Coordenada. A medida que mueve su cursos sobre el mapa, le mostrará las coordenadas X y Y en esa ubicación. En la esquina inferior derecha usted verá EPSG:4326. Este es el código para el SRC (Proyección) actual para el proyecto - también conocido como el SRC de Proyecto.

../../_images/354.png
  1. Para determinar la proyección de capa, podemos mirar los metadatos. Clic-derecho en la capa ne_10m_admin_0_countries y seleccione Propiedades.

../../_images/433.png
  1. Cámbiese a la pestaña Información en el diálogo Propiedades. Expanda la sección Información del proveedor. En la parte de abajo, verá el nombre de la proyección bajo SRC.

../../_images/533.png
  1. Ahora veamos como cambiar la proyección de la capa. Esta operación es llamada Re-Proyección. En vez de reproyectar la capa entera, podemos también seleccionar un subconjunto de los objetos espaciales y reproyectarlos a una nueva capa. Use la herramienta Seleccionar objetos espaciales por área o por clic único y haga clic en el objeto espacial Reino Unido para seleccionarlo.

../../_images/632.png
  1. Busque y localice el algoritmo Vector General ‣ Reproyectar capa

../../_images/732.png
  1. Seleccione ne_10m_admin_0_countries como la Capa de Entrada, marque Solo objetos seleccionados y luego clic en el icono globo junto a SRC Destino, busque y seleccione EPSG:27700 - OSGB 1936 / British National Grid. En Reproyectado, elija el ... y clic Guardar a archivo. Ahora elija el directorio e ingrese el nombre united_kingdom.gkpg y clic Ejecutar.

../../_images/831.png
  1. Aparecerá una nueva capa united_kingdom en el Panel de capa. Como ve, ambas capas aún se alinean exactamente entre ellas - a pesar de que tiene SRCs diferentes. Esto es debido a que QGIS admite transformación SRC al vuelo. Lo que significa que toda vez que el SRC de una capa no coincide con el SRC de Proyecto, será automáticamente transformado al SRC de Proyecto para ser mostrado correctamente. Ahora definamos el SRC de Proyecto para que coincida con SRC de la capa recién creada united_kingdom. Quite la capa ne_10m_admin_0_countries y, clic-derecho en la capa united_kingdom SRC de capa ‣ Definir SRC de Proyecto a partir de capa.

../../_images/932.png
  1. Verá que el SRC de Proyecto es actualizado a EPSG:27700.

../../_images/1031.png
  1. Ahora añadamos una capa Ráster. Vaya a Capa ‣ Añadir Capa ‣ Añadir Capa Ráster….

../../_images/1143.png
  1. Clic en ... junto a Fuente, seleccione la capa MiniScale_(standard)_R23.tif. Clic en Añadir.

../../_images/1234.png
  1. Ahora una nueva capa MiniScale_(standard)_R23 es añadida al lienzo.

../../_images/1333.png
  1. Para hacer que ambas capas sean visibles, cambie el orden de la capa arrastrando MiniScale_(standard)_R23 a lo más bajo en el panel Capas.

../../_images/1431.png
  1. Clic-derecho en la capa MiniScale_(standard)_R23 y clic en Propiedades.

../../_images/1530.png
  1. En las Propiedades de Capa, cámbiese a Información, el SRC es EPSG:27700 - OSBG 1935 / British National Grid - Projected. Esto confirma que el SRC de la capa ráster es el mismo que el SRC de Proyecto.

Nota

Si quiere reproyectar una capa ráster, puede usar el algoritmo GDAL ‣ Proyecciones ráster ‣ Combar (reproyectar)

../../_images/1628.png
comments powered by Disqus