Georeferenciar Hojas Topográficas y Mapas Escaneados (QGIS3)

La mayoría de los proyectos SIG requiere la georeferenciación de algunos datos raster. La georeferenciación es el proceso de asignar coordenadas del mundo real a cada píxel del raster. Muchas veces estas coordenadas son obtenidas haciendo estudios de campo - colectando coordenadas con un dispositivo GPS para unas pocas entidades fácilmente identificables en la imagen o mapa. En algunos casos, donde buscas digitalizar mapas escaneados, puedes obtener las coordenadas de las marcad en la misma imagen del mapa. Usando estas coordenadas de muestra o PCTs (Puntos de Control del Terreno), la imagen es ajustada y se la hace coincidir dentro del sistema de coordenada elegido. En este tutorial discutiré los conceptos, estrategias y herramientas dentro de QGIS para alcanzar una georeferenciación de alta exactitud.

Este tutorial es para georeferenciar una imagen que tiene información de coordenadas disponible en la misma imagen del mapa (i.e., cuadrículas con etiquetas). Si su imagen fuente no tiene tal información, puede usar el método bosquejado en Georeferenciar Imágenes Aéreas (QGIS3)

Vista general de la tarea

Usaremos un mapa escaneado del sur de la India de 1870 y lo georeferenciaremos usando QGIS.

Otras habilidades que aprenderá

  • Como determinar el datum y sistema de coordenada para mapas antiguos.

  • Guarde el PCT creado.

  • Edite el PCT creado para realizar un ajuste fino.

Obtener los datos

El sitio web Hipkiss’s Scanned Old Maps tiene una excelente colección de mapas escaneados sin derechos reservados que uno puede usar para investigación.

Descargue el mapa 1870 del sur de la India y guárdelo como una imagen JPG en su disco duro.

Para su comodidad, puede descargar directamente una copia del conjunto de datos del siguiente enlace:

1870_southern_india.jpg

Procedimiento

  1. Abra QGIS y haga clic en Raster ‣ Georeferenciador para abrir la herramienta.

Nota

From QGIS versions 3.26 onwards, the Georeferencer can be launched from Layer ‣ Georeferencer.

../../_images/015.png
  1. El Georreferenciador está dividido en 2 secciones. La sección superior, donde se mostrará la imagen, y la sección inferior, donde aparecerá una tabla que muestra sus PCTs.

../../_images/025.png
  1. Ahora abriremos nuestra imagen JPG. Vaya a Archivo ‣ Abrir Ráster. Navegue a la imagen descargada del mapa escaneado y clic en Abrir.

../../_images/035.png
  1. Verá que la imagen se carga en la sección superior. Puede usar los controles de acercamiento/desplazamiento en la barra de herramientas para aprender más acerca del mapa.

../../_images/045.png
  1. Ahora necesitamos asignar coordenadas a algunos puntos en este mapa. Si mira de cerca, verá una cuadrícula de coordenada con marcas. Éstas son las líneas de cuadrícula Latitud y Longitud.

../../_images/055.png
  1. Antes de añadir Puntos de Control del Terreno (PCT), necesitamos definir los ajustes de transformación. Haga clic en el icono del engranaje en la ventana de georreferenciación para abrir el diálogo de ajustes de transformación.

../../_images/065.png
  1. En el cuadro de diálogo Configuración de la transformación, seleccione el Tipo de transformación como Polinomio 2. Consulte la Documentación de QGIS para conocer los diferentes tipos de transformación y sus usos. A continuación, seleccione el Método de muestreo como Vecino más cercano. Haga clic en el botón Seleccionar SRC al lado de SRC Objetivo.

../../_images/075.png
  1. Si está georeferenciando un mapa escaneado como este, puede obtener la información de SRC del mismo mapa. Mirando nuestra imagen de mapa, las coordenadas son Latitud/Longitud. No se nos da información de datum, por lo que asumiremos una apropiada. Debido a que es India y el mapa es bastante antiguo, podemos apostar que el datum Everest 1830 nos daría buenos resultados. Busque everest y seleccione el SRC con la definición más antigua para el datum Everest (EPSG:4042). Clic en Aceptar.

../../_images/085.png

Nota

Las Cartas Survey of India Topo creadas entre el año 1960 y 2000 usan el esferoide Everest 1956 y el datum India_nepal. Si está georeferenciando Cartas SOI Topo, puede definir un SRC Personalizado en QGIS con los siguientes parámetros y usarlos en este paso. Esta definición incluye parámetros delta_x, delta_y y delta_z para transformar este datum a WGS84. Vea esta página para más información sobre el Sistema de Cuadrícula Indio.

+proj=longlat +a=6377301.243 +b=6356100.2284 +towgs84=295,736,257,0,0,0,0 +no_defs

Nota

La mayoría de los mapas son creados usando un SRC Proyectado. Si el mapa que intenta georeferenciar usa un SRC proyectado que conoce, pero las etiquetas de gratícula están en un SRC Geográfico (latitud/longitud), puede usar un flujo de trabajo alternativo para minimizar la distorsión. Use en vez un SRC Geográfico como el que estamos usando aquí, puede crear una cuadrícula vector en QGIS y transformarla al SRC proyectado a ser usado como referencia para una captura exacta de coordenada. Vea esta página para más detalles.

  1. Nombre el ráster de salida como 1870_southern_india_modified.tif. Elija LZW como Compresión. Marque la opción Guardar puntos PCT para almacenar los puntos como archivo separado para propósitos futuros. Asegúrese de que la opción Cargar en QGIS al terminar está marcada. Haga clic en Aceptar.

../../_images/095.png

Nota

Los archivos GeoTIFF sin comprimir pueden tener un tamaño muy grande. Así que comprimirlos es siempre una buena idea. Puedes aprender más sobre las diferentes opciones de compresión de TIFF (LZW, PACKBITS o DEFLATE) en este artículo.

  1. Ahora podemos empezar a añadir los Puntos de Control del Terreno (PCT). Haga clic en el botón Añadir punto.

../../_images/1015.png
  1. Ahora coloque la mira en las intersecciones de las líneas de la cuadrícula y haga clic con el botón izquierdo del ratón, esto servirá como la verdad del suelo en nuestro caso. Como las líneas de la cuadrícula están etiquetadas, podemos determinar las coordenadas X e Y de los puntos con ellas. En la ventana emergente, introduzca las coordenadas. Recuerde que X=longitud e Y=latitud. Haga clic en Aceptar.

../../_images/1118.png
  1. Notará que la tabla PCT ahora tiene una fila con detalles de su primer PCT.

../../_images/1216.png

13 . Del mismo modo, añada más PCTs que cubran toda la imagen. Cuantos más puntos tenga, más precisa será la imagen registrada en las coordenadas del objetivo. La transformación Polinomio 2 requiere al menos 6 PCTs. Una vez que haya añadido el número mínimo de puntos necesarios para la transformación, notará que los PCTs tienen ahora valores de error dX, dY y Residual distintos de cero. Si un PCT en particular tiene valores de error inusualmente altos, eso suele significar un error humano al introducir los valores de las coordenadas. Así que puede borrar ese PCT y capturarlo de nuevo. También puede editar los valores de las coordenadas en la Tabla de PCT haciendo clic en la celda de Dest. X o Dest. Y.

../../_images/1314.png
  1. Una vez que esté satisfecho con los PCTs, haga clic en el botón Iniciar Georeferenciación. Esto iniciará el proceso de deformación de la imagen utilizando los PCTs y creando el ráster de destino.

../../_images/1412.png
  1. Una vez finalizado el proceso, verá la capa georreferenciada cargada en QGIS. La georreferenciación ha finalizado. Además, observará que el SRC del proyecto en la parte inferior derecha está ajustado a EPSG:4042, tal y como se describe en Configuración de la transformación.

../../_images/1511.png
  1. Arrastre y suelte el OpenStreetMap como Mapa Base desde el desplegable XYZ Tiles en la parte inferior del panel del Navegador para verificar la capa georreferenciada. Para establecer la transparencia, haga clic en el icono Abrir panel de estilo de capas y seleccione la pestaña Transparencia. Establezca la transparencia en 40 %. Ahora la imagen georreferenciada debe superponerse al contorno del mapa base.

../../_images/1610.png
  1. Si la georreferenciación necesita más ajustes, podemos partir de los puntos PCT recogidos. Busque la ubicación del archivo 1870_southern_india_modified.tif. Encontrará un archivo adicional, 1870_southern_india_modified.tif.points. Este archivo contendrá la información de los puntos PCT.

../../_images/1711.png
  1. Abra la herramienta de georreferenciación en QGIS, haga clic en Archivo ‣ Cargar puntos PCT, y seleccione el 1870_southern_india_modified.tif.points. Esto cargará el PCT creado anteriormente. A continuación, cargue el 1870_southern_india_modified.tif para afinar su trabajo.

../../_images/189.png
comments powered by Disqus