Ustvarjanje karte

Pogosto moramo ustvariti karto za tisk ali objavo. QGIS ima vgrajeno dokaj zmogljivo orodje, ki se imenuje Print Composer in omogoča ustvarjanje kart iz podatkovnih slojev GIS.

Pregled naloge

V vadnici bomo ustvarili karto Japonske s standardnimi elementi kot so pomanjšana karta, mreža, oznaka za sever, merilo in druge oznake.

Česa se bomo še naučili

  • Spoznali bomo transformacije koordinatnega sistema CRS, tako imenovano sprotno ali ‘on-the-fly’ preprojekcijo.

Pridobivanje podatkov

Uporabili bomo podatkovno zbirko Natural Earth - bolj natačno Natural Earth Quick Start Kit, ki že vsebuje lepo oblikovane globalne podatkovne sloje in je pripravljena za uporabo v programu QGIS.

Prenesite Natural Earth Quickstart Kit.

Vir podatkov [NATURALEARTH]

Postopek

  1. Download and extract the Natural Earth Quick Start Kit data. Open QGIS. Click on File ‣ Open Project.
../_images/190.png
  1. Browse to the directory when you had extracted the natural earth data. You should see a file named Natural_Earth_quick_start_for_QGIS.qgs. This is the project file that contains styled layers in QGIS Document format. Click Open.
../_images/236.png
  1. V kazalu se prikaže veliko število slojev, v glavnem oknu QGISa pa se pojavi oblikovana karta sveta. Če se na vrhu glavnega okna pojavi kako sporočilo o napaki, ga ignorirajte in zaprite.

../_images/324.png
  1. V vadnici bomo oblikovali karto Japonske. Kliknite gumb Zoom In, s povečevalnim steklom narišite pravokotnik okrog Japonske in se tako približajte opazovanemu območju.

../_images/418.png
  1. Ker na tej karti ne potrebujemo vseh slojev, jih lahko del izklopimo. Odstranite križce pri slojih 10m_geography_marine_polys in 10m_admin_0_map_units. Preden karto pripravimo za objavo oziroma tisk, moramo izbrati ustrezno projekcijo. Surovi podatki prihajajo v geografskih koordinatah (GCS, Geographic Coordinate System), pri katerih je podana geografska širina in geografska dolžina v stopinjah. Za karto, na kateri želimo imeti razdalje v kilometrih to ni primerno. Potrebujemo projicirane podatke v koordinatnem sistemu, ki zmanjša popačenja na izbranem območju in ima enote v metrih. Primerna izbira je sistem UTM (Universal Transverse Mercator). Gre za globalni sistem, ki ga lahko uporabimo po vsem svetu, izbrati moramo le ustrezno cono. V primeru Japonske je to cona 54N (UTM Zone 54N). Kliknite gumb CRS Status v spodnjem desnem delu okna programa QGIS.

Opomba

Japonska uporablja projekcijski koordinatni sistem (coordinate reference system, CRS) z imenom Japan Plane Rectangular CS, ki kar se da zmanjša popačenja. Razdeljen je na 18 con in če bi delali na manjšem območju Japonske, bi bil ta sistem primernejši.

../_images/518.png
  1. Izberite potrdilno polje Enable on-the-fly CRS Transformation . Vpišite Tokyo utm zone54n iv iskalno polje Filter search box. Ko se prikažejo rezultati, izberite Tokyo / UTM Zone 54N - EPSG:3095. Kliknite Apply.

../_images/617.png
  1. Zdaj lahko začnemo oblikovati karto. Izberite Project ‣ New Print Composer.

../_images/716.png
  1. Pojavilo se bo okno za vpis naslova kompozicije. Lahko ga pustimo praznega in kliknemo Ok.

Opomba

Če pustimo polje prazno, bo karta dobila privzeto ime, na primer Composer 1.

../_images/816.png
  1. V oknu postavitve tiskanja kliknite Zoom full, da karte zapolni celotno okno. Zdaj lahko na risalno površino dodamo karto, ki je prikazana v glavnem oknu QGISa. Izberite Layout ‣ Add Map.

../_images/1015.png
  1. Ko je aktiven gumb Add Map, kliknite in držite levi gumb na miški ter narišite pravokotnik v katerega želite postaviti karto.

../_images/1118.png
  1. V pravokotniku se bo pojavila karta iz glavnega okna QGISa. Lahko se zgodi, da karta ne bo prekrivala celotnega zanimivega območja. Izberite Layout ‣ Move item content ter premaknite karto v okvirju ter jo usredinite v oknu za urejanje kart.

../_images/1217.png
  1. Določimo še faktor povečave oziroma pomanjšave karte. Kliknite kartico Item Properties in vpišite 7000000 za vrednost Scale value.

../_images/1315.png
  1. Dodali bomo še manjšo karto (vložek), na kateri bomo prikazali območje Tokia. Preden naredimo spremembe v glavnem oknu QGISa, označite izbirni polji Lock layers for map item in Lock layer styles for map item. S tem bomo poskrbeli, da se pogled ne bo spremenil ko bomo izklopili posamezne sloje ali pa spremenili njihove sloge.

../_images/1413.png
  1. Preklopite na glavno okno QGISa. Uporabite gumb Zoom In in se približajte območju Tokia.

../_images/1513.png
  1. Pojavi se nekaj podvojenih oznak. Te prihajajo iz sloja ne_10m_populated_places, ki ga zato za ta pogled izklopimo.

../_images/1612.png
  1. Vložek je pripravljen in ga lahko dodamo glavni karti. Najprej preklopite v okno Print Composer. Izberite meni Layout ‣ Add Map.

../_images/1711.png
  1. Na mestu, kjer želite imeti pomanjšano karto, narišite pravokotnik. V oknu Print Composer imamo zdaj 2 objekta oziroma dve karti. Zato moramo biti pazljivi, da imamo izbrano pravi objekt, ko izvajamo spremembe. Na nadzorni plošči Items izberite objekt Map 1, ki smo ga pravkar dodali. Izberite kartico Item properties tab. Premaknite se navzdol do dela Frame in izberite polje pred njim. Izberete lahko barvo in debelino okvirja, s čimer ga boste vizualno ločili od ozadja.

../_images/1811.png
  1. Prikladna lastnost okna Print Composer je, da samodejno poudari območje na glavni karti, ki je prikazano na vložku. Izberite objekt Map 0 iz nadzorne plošče Items. Na kartici Item properties, pojdite do dela Overviews . kliknite gumb Add a new overview.

../_images/199.png
  1. Izberite Map 1 kot Map Frame. S tem Print Composer objekt Map 1 poudari (označi) na objektu Map 0.

../_images/206.png
  1. Pripravljen imamo vložek, zato lahko na glavno karto dodamo mrežo in okvir z enotami. Izberite objekt Map 0 v nadzorni plošči Items panel. Na krtici Item properties poiščite razdelek Grids. Kliknite gumb Add a new grid.

../_images/2112.png
  1. Mrežne črte privzeto uporabljajo enote trenutno izbrane projekcije. Pogosto pa je uporabnejše prikazati mrežne črte v drugih enotah, recimo v stopinjah. Za mrežo lahko izberemo drugo projekcijo CRS. Kliknite gumb change... poleg CRS.

../_images/2211.png
  1. V pogovornem oknu Coordinate Reference System Selector v polju Filter vtipkajte 4326. Iz prikazanih rezultatov izberite WGS84 EPSG:4326 kot CRS in kliknite OK.

../_images/237.png
  1. V polju Interval izberite vrednot 5 stopinj za smeri X in Y. Z Offset lahko določimo tudi položaj, kjer se pojavijo mrežne črte.

../_images/245.png
  1. Premaknite se do razdelka Grid frame in izberite tip okvirja, ki vam je všeč. Označite izbirno polje Draw coordinates.

../_images/254.png
  1. Spremenite Distance to map frame tako, da bodo koordinate berljive. V polju Coordinate precision nastavite vrednost 1, s čimer koordinate zaokrožite na eno decimalko.

../_images/264.png
  1. Karti bomo dodali oznako za sever. Orodje za postavljanje kart vsebuje veliko ikon za opremljanje kart, med njimi je tudi več oznak za sever. Izberite Layout ‣ Add Image.

../_images/274.png
  1. Kliknite levi gumb in narišite pravokotnik v zgornjem desnem kotu območja karte. V desni plošči kliknite kartico Item Properties, razširite razdelek Search directories in izberite oznako za sever.

../_images/282.png
  1. Now we will add a scale bar. Click on Layout ‣ Add Scalebar.
../_images/293.png
  1. Kliknite postavitev merila, ki vam ustreza. Na kartici Item Properties pazite, da boste izbrali element karte, za katerega želite merilo, in določite primeren slog. Na nadzorni plošči Segments lahko določite število segmentov in njihovo velikost.

../_images/303.png
  1. Zdaj lahko karto poimenujemo. Kliknite Layout ‣ Add Label.

../_images/3111.png
  1. Izbreite karto in narišite okvir za naslov. Na kartici Item Properties razširite razdelek Label in vpišite spodnje besedilo. Vnašamo lahko tudi oznake HTML. Pazite, da je izbrano polje Render as Html in bodo oznake HTML pravilno interpretirane.

<div align=center>
<h1>Map of Japan</h1>
</div>
../_images/325.png
  1. S podobnim postopkom dodamo še drugo oznako z navedbo vira podatkov in uporabljene programske opreme.

../_images/332.png
  1. Ko ste s karto zadovoljni, jo lahko izvozite kot rastrsko sliko, kot PDF ali kot SVG. Za to vadnico jo bomo izvozili kot sliko PNG. Kliknite Composer ‣ Export as Image.

../_images/342.png
  1. Shranite sliko v poljubnem zapisu. Tule je slika v obliki PNG, ki je primerna za vključevanje v dokumente.

../_images/352.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License