Ustvarjanje karte (QGIS3)

Pogosto moramo ustvariti karto za tisk ali objavo. QGIS ima vgrajeno dokajzmogljivo orodje, ki se imenuje Print Layout in omogočaustvarjanje kart iz podatkovnih slojev GIS.

Pregled naloge

V vadnici bomo ustvarili karto Japonske s standardnimi elementi kot so pomanjšana karta, mreža, oznaka za sever, merilo in druge oznake.

Česa se bomo še naučili

  • Kako pregledati in spremeniti spremenljivke oziroma nastavitve projekta QGIS

  • Kako uporabljati izraze v QGISu

Pridobivanje podatkov

Uporabili bomo podatkovno zbirko Natural Earth - bolj natačno Natural Earth Quick Start Kit, ki že vsebuje lepo oblikovane globalne podatkovne sloje in je pripravljena za uporabo v programu QGIS.

Prenesite Natural Earth Quickstart Kit.

Vir podatkov [NATURALEARTH]

Postopek

  1. Prenesite in razširite podatke Natural Earth Quick Start Kit. Odprite QGIS. Poiščite mapo Natural Earth quick start v Browser nadzorni plošči. Razširite mapo in poiščite projekt Natural_Earth_quick_start_for_QGIS_v3. Ta je projektna datoteka, ki vsebuje sloje v obliki QGIS dokumentov. Dvakrat kliknite projekt, da ga odprete.

../../_images/199.png
  1. Verjetno boste opazili, da ima karta oznake v grščini. Projekt ima nastavljeno spremenljivko jezik. To lahko spremenimo tako, da gremo v Project ‣ Properties.

../../_images/240.png

Opomba

Projektne spremenljivke so odličen način za shranjevanje nastavitev, ki jih lahko nato uporabimo povsod, kjer QGIS omogoča delo s spremenljivkami. Projekt Natural_Earth_quick_start_for_QGIS_v3 ima že nastavljenih veliko spremenljivk, ki jih uporabljamo za oblikovanje v tem projektu.

  1. Preklopite na zavihek Variables v pogovornem oknu Project Properties. Poiščite spremenljivko project_language in klliknite Value stolpec, da pričnete z urejanjem. Spremenite jezik v name_en in kliknite OK.

../../_images/330.png
  1. Ko se vrnete v glavno okno programa QGIS, kliknite gumb Refresh v Map Navigation Toolbar. Karto boste zdaj videli prikazano z angleškimi oznakami.

../../_images/416.png
  1. Use the pan and zoom controls in the Map Navigation Toolbar and zoom to Japan.

../../_images/516.png
  1. Ker na tej karti ne potrebujemo vseh slojev, jih lahko del izklopimo. Razširite mapo z5 - 1:18m in odstranite oznake pri slojih ne_10m_geography_marine_polys in ne_10m_admin_0_disputed_areas. Preden karto pripravimo za objavo oziroma tisk, moramo izbrati ustrezno projekcijo. Projekcija projekta (CRS, coordinate referece system) je nastavljena na EPSG:3857 Pseudo-Mercator. To je priljubljena projekcija za spletno kartiranje in je primerna tudi za naš namen, zato jo lahko obdržimo. Pojdite v Project ‣ New Print Layout.

../../_images/616.png

Opomba

Japonska uporablja projekcijski koordinatni sistem (coordinate reference system, CRS) z imenom Japan Plane Rectangular CS, ki kar se da zmanjša popačenja. Razdeljen je na 18 con in če bi delali na manjšem območju Japonske, bi bil ta sistem primernejši.

  1. Pojavilo se bo okno za vpis naslova postavitve. Lahko ga pustimo praznega in kliknemo Ok.

../../_images/715.png

Opomba

Če pustimo polje prazno, bo karta dobila privzeto ime, na primer Layout 1.

  1. V oknu Print Layout , kliknite gumb Zoom full in prikažite celotno karto.

../../_images/815.png
  1. Zdaj lahko na risalno površino dodamo karto, ki je prikazana v glavnem oknu QGISa. Izberite Add Item ‣ Add Map.

../../_images/915.png
  1. Ko je aktiven gumb Add Map, kliknite in držite levi gumb na miški ter narišite pravokotnik, v katerega želite postaviti karto.

../../_images/1015.png
  1. V pravokotniku se bo pojavila karta iz glavnega okna QGISa. Lahko se zgodi, da karta ne bo prekrivala celotnega zanimivega območja. Izberite Edit ‣ Select/Move item in Edit ‣ Move Content ter premaknite karto v okvirju ter jo usredinite v oknu za urejanje kart.

../../_images/1119.png
  1. Določimo še faktor povečave oziroma pomanjšave karte. Kliknite kartico Item Properties in vpišite 10000000 za vrednost Scale.

../../_images/1216.png
  1. Dodali bomo še manjšo karto (vložek), na kateri bomo prikazali območje Tokia. Preden naredimo spremembe v glavnem oknu QGISa, označite izbirni polji Lock layers in Lock styles for layers. S tem bomo poskrbeli, da se pogled ne bo spremenil, ko bomo izklopili posamezne sloje ali pa spremenili njihove sloge.

../../_images/1315.png
  1. Switch to the main QGIS window. Turn off the layer group z5 - 1:18m and activate the z7 - 1: 4m group. This layer group has styling that is more appropriate for a zoomed-in view. Use the pan and zoom controls in the Map Navigation Toolbar and zoom around Tokyo.

../../_images/1414.png
  1. Vložek je pripravljen in ga lahko dodamo glavni karti. Najprej preklopite v okno Print Layout. Izberite meni Add Item ‣ Add Map.

../../_images/1513.png
  1. Na mestu, kjer želite imeti pomanjšano karto, narišite pravokotnik. V pogledu Print Layout imamo zdaj dva elementa. Zato moramo biti pazljivi, da imamo izbrano pravi objekt, ko izvajamo spremembe.

../../_images/1612.png
  1. Na nadzorni plošči Items izberite objekt Map 2, ki smo ga pravkar dodali. Izberite kartico Item properties. Premaknite se navzdol do dela Frame in izberite polje pred njim. Izberete lahko barvo in debelino okvirja, s čimer ga boste vizualno ločili od ozadja.

../../_images/1713.png
  1. Prikladna lastnost okna Print Layout je, da samodejno poudari območje na glavni karti, ki je prikazano na vložku. Izberite objekt Map 1 iz nadzorne plošče Items. Na kartici Item properties, pojdite do dela Overviews . kliknite gumb Add a new overview.

../../_images/1811.png
  1. Izberite Map 2 kot Map Frame. S tem Print Layout na trenutnem objektu Map 1 poudari (označi) objekt Map 2.

../../_images/1910.png
  1. Pripravljen imamo vložek, zato lahko na glavno karto dodamo mrežo in okvir z enotami. Izberite objekt Map 1 v nadzorni plošči Items panel. Na kartici Item properties poiščite razdelek Grids. Kliknite gumb Add a new grid in nato gumb Modify grid….

../../_images/208.png
  1. Mrežne črte privzeto uporabljajo enote trenutno izbrane projekcije. Pogosto pa je uporabnejše prikazati mrežne črte v drugih enotah, recimo v stopinjah. Za mrežo lahko izberemo drugo projekcijo CRS. Kliknite gumb Change… poleg CRS.

../../_images/2114.png
  1. V pogovornem oknu Coordinate Reference System Selector v polju Filter vtipkajte 4326. Iz prikazanih rezultatov izberite WGS84 EPSG:4326 kot CRS in kliknite OK.

../../_images/2211.png
  1. V polju Interval izberite vrednot 5 stopinj za smeri X in Y. Z Offset lahko določimo tudi položaj, kjer se pojavijo mrežne črte.

../../_images/2311.png
  1. Premaknite se navzdol do razdelka Grid frame in označite polje Draw coordinates box. Privzeta oblika je Degrees, prikazana pa je samo kot število. To lahko popravimo in oddamo znak °. Izberite Custom in kliknite gumb Expression.

../../_images/246.png
  1. Vnesite naslednji izraz, da ustvarite niz, ki zavzame številko mreže in doda simbol °.

concat(to_string(@grid_number), '°    ')
../../_images/255.png
  1. Opazili boste, da ima mreža zdaj novo oznako, ki je določena z izrazom. Prilagodite položaj z možnostmi Left, Right, Top in Bottom kot vam je všeč.

../../_images/265.png
  1. Dodali bomo pravokotni okvir za dodatne elemente karte, recimo vetrovnico, merilo in naslov. Izberite Add Item ‣ Add Shape ‣ Add Rectangle.

../../_images/275.png
  1. Spremenite lahko Style tako, da bo okvir prilagojen karti v ozadju.

../../_images/284.png
  1. Karti bomo dodali vetrovnico, to je oznako za sever. Orodje za postavljanje kart vsebuje veliko ikon za opremljanje kart, med njimi je tudi več oznak za sever. Izberite Add Item ‣ Add Picture.

../../_images/294.png
  1. Kliknite levi gumb in narišite pravokotnik. V desni plošči kliknite kartico Item Properties, razširite razdelek Search directories in izberite oznako za sever, ki vam je všeč.

../../_images/304.png
  1. V naslednjem koraku bomo dodali merilo. Izberite Add Item ‣ Add Scalebar.

../../_images/3111.png
  1. Kliknite postavitev merila, ki vam ustreza. Na kartici Item Properties pazite, da boste izbrali element karte, za katerega želite merilo, to je Map 1. Določite primeren slog. Na nadzorni plošči Segments lahko določite število segmentov in njihovo velikost. Izberite 200 v Fixed width.

../../_images/3210.png
  1. Zdaj lahko karto poimenujemo. Kliknite Add Item ‣ Add Label.

../../_images/332.png
  1. IzbKliknite na karto in narišite okvir za naslov. Na zavihku Item Properties razširite razdelek Label in vpišite ime oziroma naslov karte. Podobno lahko dodate druge oznake, recimo avtorja ali navedbo virov.

../../_images/342.png
  1. Ko ste s karto zadovoljni, jo lahko izvozite kot rastrsko sliko, kot PDF ali kot SVG. Za to vadnico jo bomo izvozili kot sliko PNG. Kliknite Layout ‣ Export as Image.

../../_images/352.png
  1. Shranite sliko v poljubnem zapisu. Tule je slika v obliki PNG, ki je primerna za vključevanje v dokumente.

../../_images/output.png
comments powered by Disqus