Erstellung einer Karte (QGIS3)

Oftmals ist die Erstellung einer Karte zum Druck oder zur Veröffentlichung erforderlich. In QGIS ist ein mächtiges Tool Drucklayout enthalten, dass es ermöglicht, die enthaltenen Layer zu einer Karte zu gestalten.

Überblick über die Aufgabe

Diese Anleitung zeigt die Erstellung einer Karte von Japan mit Standardkartenelementen wie Kartenausschnitt, Gitter, Nordpfeil, Maßstabsleiste und Beschriftungen.

Weitere Fähigkeitem die wir erlernen

  • Wie man sich Projekt-Variablen ansieht und sie verändert

  • Wie man QGIS Ausdrücke verwendet

Beschaffung der Daten

Wir verwenden einen Datensatz von Natural Earth, genauer gesagt das Natural Earth Quick Start Kit. Das Kit wird mit wunderschön gestalteten globalen Layern geliefert, die direkt in QGIS geladen werden können.

Man kann die Daten hier herunterladen: Natural Earth Quickstart Kit.

Datenquelle [NATURALEARTH]

Arbeitsablauf

  1. Wir laden die Daten des Natural Earth Quick Start Kit herunter und entpacken sie. Öffne QGIS. Gehe im Browser Bereich zum Ordner Natural Earth quick start. Erweitere den Ordner und suche das Projekt Natural_Earth_quick_start_for_QGIS_v3. Dieses Projekt enthält die gestalteten Layer im QGIS Dateiformat. Klicke doppelt auf das Projekt, um es zu öffnen.

../../_images/190.png
  1. Wir sehen, dass die Karte griechische Beschriftungen verwendet. Das Projekt verwendet Variablen, um die Sprache festzulegen. Wir können die Variablen unter Projekt ‣ Eigenschaften ändern.

../../_images/239.png

Bemerkung

Projektvariablen sind eine großartige Form der Speicherung von projektspezifischen Werten. Man kann Werte in QGIS überall dort verwenden, wo Ausdrücke eingesetzt werden. Das Projekt Natural_Earth_quick_start_for_QGIS_v3 enthält bereits viele vordefinierte Variablen, die für die Gestaltung im Projekt verwendet werden.

  1. Gehe im Dialogfenster Projekteigenschaften zum Feld Variablen. Gehe zur Variable project_language und klicke auf die Spalte Wert um sie anzupassen. Ändere die Sprache zu name_de und klicke auf OK.

../../_images/329.png
  1. Zurück im QGIS Fenster klicken wir auf den Knopf Aktualisieren in der Kartennavigationswerkzeugleiste. Die Beschriftungen werden nun in deutsch angezeigt.

../../_images/415.png
  1. Use the pan and zoom controls in the Map Navigation Toolbar and zoom to Japan.

../../_images/515.png
  1. Wir können einige Kartenlayer, die wir für diese Karte nicht benötigen, ausschalten. Erweitere die Gruppe z5 - 1:18m und schalte die Layer ne_10m_geography_marine_polys und ne_10m_admin_0_disputed_areas aus. Bevor wir eine Karte zum Druck anpassen können, müssen wir eine passende Koordinatentransformation festlegen. Das im voreingestellte KBS ist EPSG:3857 Pseudo-Mercator. Dabei handelt es sich um ein oft für web mapping genutztes KBS. Das KBS ist für unsere Zwecke gut geeignet, so dass wir es so belassen können. Gehe zu Projekt ‣ Neues Drucklayout.

../../_images/615.png

Bemerkung

Für Japan gibt es das KBS Japan Plane Rectangular CS. Es handelt sich um ein projiziertes Koordinatenreferenzsystem (KBS), das für minimale Verzerrungen erstellt wurde. Es ist in 18 Zonen unterteilt. Wenn man mit kleineren Regionen in Japan arbeit, ist dieses KBS besser geeignet.

  1. Wir erhalten die Aufforderung, einen Drucklayout-Titel zu vergeben. Wir lassen das Eingabefeld leer und drücken auf Ok.

../../_images/714.png

Bemerkung

Durch das Leerlassen wird ein Standardname wie Layout 1 verwendet.

  1. Wir klicken im Drucklayoutfenster auf den Knopf Volle Ausdehnung, um die gesamte Größe des Layouts anzuzeigen.

../../_images/814.png
  1. Als nächstes müssen wir den Inhalt der QGIS Kartenansicht in das Layout übertragen. Wir gehen zu Element hinzufügen ‣ Karte hinzufügen.

../../_images/914.png
  1. Nachdem der Modus Karte hinzufügen aktiv ist, ziehen wir mit der gedrückten linken Maustaste einen Rahmen für den Bereich der Karte auf.

../../_images/1014.png
  1. Das rechteckige Fenster enthält jetzt den Karteninhalt aus der QGIS Kartenansicht. Es kann sein, dass nicht der gesamte gewünschte Inhalt angezeigt wird. Mit Bearbeiten ‣ Eintrag wählen/verschieben und Bearbeiten ‣ Inhalt verschieben können wir die Karte verschieben oder zentrieren.

../../_images/1118.png
  1. Wir passen noch die Zoomstufe der Karte an. Klicke auf den Reiter Elementeigenschaften und gebe 10000000 als Maßstab ein.

../../_images/1215.png
  1. Als nächstes werden wir einen Kartenausschnitt mit einer vergrößerten Ansicht Tokios hinzufügen. Bevor wir eine Änderung im QGIS Hauptfenster vornehmen, setzen wir einen Haken bei Layer sperren und bei Layerstile sperren. Damit stellen wir sicher, dass sich das Layout beim Ausschalten oder Verändern der Darstellung einiger Layer nicht verändert.

../../_images/1314.png
  1. Switch to the main QGIS window. Turn off the layer group z5 - 1:18m and activate the z7 - 1: 4m group. This layer group has styling that is more appropriate for a zoomed-in view. Use the pan and zoom controls in the Map Navigation Toolbar and zoom around Tokyo.

../../_images/1413.png
  1. Wir können nun den Kartenausschnitt hinzufügen. Gehe zum Drucklayout Fenster und dort zu Elemente hinzufügen ‣ Karte hinzufügen.

../../_images/1512.png
  1. An der Stelle, wo der Kartenausschnitt hinzugefügt werden soll, ziehen wir ein Rechteck auf. Wir haben jetzt 2 Kartenobjekte im Drucklayout. Bei Änderungen müssen wir darauf achten, dass wir die richtige Karte gewählt haben.

../../_images/1611.png
  1. Wir wählen das Objekt Karte 2, das wir gerade zum Elemente Reiter hinzugefügt haben. Wähle den Reiter Elementeigenschaften und scrolle nach unten bis zu Rahmen. Setze dort einen Haken. Man kann die Farbe und Dicke des Rahmens anpassen, so dass er sich gut vom Kartenhintergrund abhebt.

../../_images/1712.png
  1. Ein praktisches Feature des Printlayouts ist, dass es automatisch den Teil der Karte hervorheben kann, das den Ausschnitt enthält. Wir wählen das Objekt Karte 1 aus dem Elemente Reiter. Im Reiter Elementeigenschaften scrollen wir nach unten zu Übersichten. Hier klicken wir auf den Knopf Eine neue Übersicht hinzufügen.

../../_images/1810.png
  1. Wähle Karte 2 als Kartenrahmen. Damit erkennt das Drucklayout, dass in Karte 1 der Bereich der Karte 2 hervorgehoben werden soll.

../../_images/198.png
  1. Nachdem wir den Kartenausschnitt fertiggestellt haben, fügen wir ein Gitter zur Hauptkarte hinzu. Wähle das Objekt Karte 1 im Reiter Elemente. Scrolle im Reiter Elementeigenschaften nach unten bis zu Gitter. Klicke auf den Knopf Neues Gitter hinzufügen und danach auf Gitter ändern….

../../_images/207.png
  1. Als Voreinstellung verwenden die Gitterlinien dieselbe Einheit und Projektion wie das Kartenprojekt. Allerdings ist es üblicher, die Gitterlinien in Grad anzuzeigen. Wir können für die Gitterlinien ein abweichendes KBS verwenden. Klicke auf den Knopf Ändern… neben KBS.

../../_images/2113.png
  1. Im Dialogfenster Koordinatenbezugssystem-Auswahl geben wir 4326 im Feld Filter ein. Aus den Ergebnissen wählen wir WGS84 EPSG:4326 als KBS. Klicke auf OK.

../../_images/2210.png
  1. Wir wählen als Intervall Werte von 5 Grad sowohl für die X als auch für die Y Richtung. Man kann den Versatz anpassen, um festzulegen, wo die Gitterlinien beginnen.

../../_images/2310.png
  1. wir scrollen im Reiter Elementeigenschaften weiter nach unten und setzen einen Haken bei Koordinaten zeichnen. Die Voreinstellung sind Grad im numerischen Format. Mit einer Anpassung kann das ° Symbol angehängt werden. Wir wählen Angepasst und klicken auf den Knopf Ausdruck daneben.

../../_images/246.png
  1. Verwende den folgenden Ausdruck, um eine Zeichenkette zu erstellen, die das ° Symbol an die Gitternummer anhängt.

concat(to_string(@grid_number), '°    ')
../../_images/255.png
  1. Wir sehen, dass die Gitter jetzt eine entsprechend des Ausdrucks angepasste Beschriftung verwenden. Die Lage der Beschriftung können wir mit Hilfe der Parameter bei Links, Rechts, Oben und Unten anpassen.

../../_images/265.png
  1. Als Nächstes fügen wir einen rechteckigen Rahmen für andere Kartenelemente wir Norpfeil, Maßstabsleiste und Beschriftung hinzu. Wir gehen zu Element hinzufügen ‣ Form hinzufügen ‣ Rechteck hinzufügen.

../../_images/275.png
  1. Wir können die Stil des Rechtecks anpassen, so dass er zum Kartenhintergrund passt.

../../_images/284.png
  1. Wir werden nun einen Nordpfeil zur Karte hinzufügen. QGIS enthält eine schöne Sammlung an Bildern zur Kartengestaltung, u.a. auch viele Arten von Nordpfeilen. Klicke auf Element hinzufügen ‣ Bild hinzufügen.

../../_images/294.png
  1. Mit gedrückter linker Maustaste ziehen wir ein Rechteck auf. Im Reiter Elemteigenschaften gehen wir zu Verzeichnisse durchsuchen und wählen ein Bild aus.

../../_images/304.png
  1. Jetzt fügen wir eine Maßstabsleiste hinzu. Gehe zu Element hinzufügen ‣ Maßstab hinzufügen.

../../_images/3111.png
  1. Klicke im Kartenlayout auf die Stelle, an der die Maßstabsleiste dargestellt werden soll. Im Reiter Elementeigenschaften stellen wir sicher, dass die richtige Karte Karte 1 gewählt ist. Wähle einen Stil aus. Im Bereich Segmente ändern wir Feste Breite zu 200 Einheiten und passen die Segmente an unsere Wünsche an.

../../_images/3210.png
  1. Jetzt müssen wir unsere Karte noch beschriften. Klicke auf Element hinzufügen ‣ Beschriftung hinzufügen.

../../_images/332.png
  1. Klicke dort auf die Karte wo das Label erscheinen soll. Im Reiter Elementeigenschaften erweitern wir den Bereich Beschriftung und vergeben eine Beschriftung für die Karte. Genauso können wir weitere Angaben zur Daten- und Softwarequelle hinzufügen.

../../_images/342.png
  1. Wenn wir mit der Darstellung zufrieden sind, können wir die Karte als Bild, PDF oder SVG exportieren. Für dieses Tutorial exportieren wir als Bild. Klicke auf Layout ‣ Als Bild exportieren.

../../_images/352.png
  1. Speichere das Bild im gewünschten Format. Unten ist das exportierte Bild im PNG Format.

../../_images/output.png
comments powered by Disqus