Creando un Mapa

Advertencia

Este tutorial está ahora obsoleto. Está disponible una versión nueva y actualizada en Haciendo un Mapa (QGIS3)

Con frecuencia se necesita crear un mapa que pueda ser impreso o publicado. QGIS tiene una poderosa herramienta llamada Composición de Impresión que le permite tomar sus capas de SIG y empaquetarlas para crear mapas.

Resumen de la Tarea

El tutorial muestra cómo crear un mapa de Japón con elementos estándar, como el mapa insertado, cuadrículas, norte, barra de escala y etiquetas.

Otras habilidades que aprenderá

  • Utilizando transformación de SRC “al-vuelo” para visualizar su información en una proyección diferente.

Obtener los datos

Vamos a utilizar el conjunto de datos «Natural Earth», más específicamente el «Estuche de Inicio Rápido Natural Earth», que incluye con capas globales bellamente decoradas que pueden ser cargadas directamente en QGIS.

Descargue el Estuche de Inicio Rápido Natural Earth.

Fuente de Datos [NATURALEARTH]

Procedimiento

  1. Descargue y extraiga los datos del «Estuche de Inicio Rápido Natural Earth». Abra QGIS. Haga clic en Archivo ‣ Abrir Proyecto.

../_images/1180.png
  1. Ubique la carpeta donde extrajo el conjunto de datos de «Natural Earth». Allí usted debería encontrar un archivo llamado Natural_Earth_quick_start_for_QGIS.qgs. Este es el archivo del proyecto que contiene las capas con estilos ya creados con el formato de documento de QGIS. Haga clic en Abrir.

../_images/2146.png
  1. Usted podrá ver bastantes capas en la tabla de contenido y un mapa del mundo con estilos en la pantalla de QGIS. Si ve notificaciones de error desplegadas en la parte superior del lienzo, haga clic en la cruz para cerrarlas.

../_images/378.png
  1. En este tutorial vamos a hacer un mapa de Japón. Haga clic en el botón Acercar y dibuje un rectángulo alrededor de Japón para ampliar a la zona.

../_images/453.png
  1. Puede desactivar algunas capas de información que no necesitamos en este mapa. Desmarque las capas 10m_geography_marine_polys y 10m_admin_0_map_units. Antes de hacer un mapa adecuado para la impresión, tenemos que elegir una proyección apropiada. Este conjunto de datos se presenta en Sistema de Coordenadas Geográficas (SCG), donde las unidades son grados. Esto no es apropiado para un mapa en el que se desea que las distancias sean en kilómetros o millas. Tenemos que utilizar un Sistema de Coordenadas Proyectadas que minimiza las distorsiones de nuestra región de interés y tiene unidades en metros. Universal Transverse Mercator (UTM) es una opción de sistema de coordenadas proyectadas decente. También es global, por lo tanto es un buen valor por defecto en el cual confiar y elegir una zona UTM que contenga su área de interés para minimizar distorsiones para su región. En nuestro caso, utilizaremos UTM Zona 54N. Hacer clic en el botón :guilaberl:`CRES Status`, abajo a la derecha en la ventana de QGIS

Nota

Para Japón, el SC Rectangular Plano Japón es un sistema de referencia de coordenadas (SRC) proyectado diseñado para distorsiones mínimas.. Está dividido en 18 zonas y si está trabajando para un región más pequeña en Japón, será mejor usar este SRC.

../_images/549.png
  1. Marque la casilla Habilitar Transformación SRC al vuelo. Escriba Tokyo utm zone54n en la caja de búsqueda Filtro. Una vez que vea los resultados, seleccione Tokyo / UTM Zone 54N - EPSG:3095. Clic en Aplicar.

../_images/647.png
  1. Ahora podemos comenzar a ensamblar nuestro mapa. Vaya a Proyecto ‣ Nueva Composición de Impresión.

../_images/746.png
  1. Se le pedirá que introduzca un título para la creación del mapa. Puede dejarlo vacío y hacer clic en Aceptar.

Nota

Dejar el nombre del compositor vacío asignará un nombre predeterminado como Composición 1.

../_images/845.png
  1. En la ventana Composición de Impresión, clic en Acercamiento total para mostrar la extensión completa del Diseño. Ahora tendríamos que traer la vista de mapa que vemos en la Pantalla QGIS al diseñador. Vaya a Diseño ‣ Añadir Mapa.

../_images/1052.png
  1. Una vez que el botón Añadir Mapa esté activo, presione el botón izquierdo del ratón y arrastre un rectángulo donde quiere insertar el mapa.

../_images/1181.png
  1. Verá que la ventana rectángulo será representada con el mapa de la pantalla principal QGIS. Puede que el mapa representado no cubra la extensión total del área de interés. Seleccione Diseño ‣ Mover contenido de elemento para desplazar el mapa en la ventana y centrarlo en el diseñador.

../_images/1254.png
  1. Ajustemos el nivel de acercamiento para un mapa dado. Clic en la pestaña Propiedades del Elemento`e ingrese `7000000 para el valor Escala.

../_images/1352.png
  1. Ahora agregaremos un mapa insertado que muestra una vista acercada al área de Tokio. Antes que hagamos cualquier cambio a las capa en la ventana principal QGIS, marque las casillas Bloquear capas para elemento mapa y Bloquear estilos de capa para elemento mapa. Esto asegurará que si desactivamos algunas capas o cambiamos sus estilos, esta vista no cambiará.

../_images/1448.png
  1. Cambie a la ventana principal QGIS. Use el botón Acercar para acercarse al área alrededor de Tokio.

../_images/1546.png
  1. Hay algunas etiquetas duplicadas que vienen de la capa ne_10m_populated_places. Puede desactivarla para esta vista.

../_images/1643.png
  1. Ahora estamos listos para agregar el mapa insertado. Cambie a la ventana Composición de Impresión. Vaya a Diseño ‣ Añadir Mapa.

../_images/1739.png
  1. Arrastre un rectángulo en el lugar donde quiere añadir el mapa insertado. Notará que ahora tiene 2 objetos mapa en la Composición de Impresión. Cuando haga cambios, asegúrese que tiene el mapa correcto seleccionado. Seleccione el objeto Mapa 1 que recién agregamos del panel Elementos. Seleccione la pestaña Propiedades de Elemento. Deslícese hacia abajo hacia el panel Marco y marque la casilla junto a él. Puede cambiar el color y grosor del borde del marco de manera que sea fácil de distinguir respecto al fondo del mapa.

../_images/1837.png
  1. Una funcionalidad estupenda de la Composición de Impresión es que puede resaltar automáticamente el área del mapa principal que está representada en su mapa insertado. Seleccione el objeto Mapa 0 del panel Elementos. En la pestaña Propiedades de Elemento, deslícese hacia abajo hacia la sección Vista general. Clic el botón Añadir una nueva vista general.

../_images/1929.png
  1. Seleccione Mapa 1 como el Marco de Mapa. Lo que esto dice la Composición de Impresión es que debe resaltar nuestro objeto actual Mapa 0 con la extensión del mapa mostrado en el objeto Mapa 1.

../_images/2024.png
  1. Ahora que tenemos listo el mapa insertado, agregaremos una cuadrícula y borde cebra al mapa principal. Seleccione el objeto Mapa 0 del panel Elementos. En la pestaña Propiedades de Elemento, deslice hacia la sección Cuadrículas. Clic el botón Añadir una nueva cuadrícula.

../_images/2147.png
  1. De forma predeterminada, las líneas de cuadrícula usan las mismas unidades y proyecciones que las proyecciones de mapa de actualmente seleccionadas. Sin embargo, es más común y útil mostrar líneas de cuadrícula en grados. Podemos seleccionar un SRC diferente para la cuadrícula. Clic en el botón Cambiar… junto a SRC.

../_images/2225.png
  1. En el diálogo Selector de Sistema de Referencia de Coordenadas, ingrese 4326 en la caja Filtro. De los resultados, seleccione WGS84 EPSG:4326 como el SRC. Clic en Aceptar.

../_images/2323.png
  1. Seleccione los valores Intervalo como 5 grados tanto en la dirección X como Y. Puede ajustar el Desplazamiento para cambiar donde aparecen las líneas de cuadrícula.

../_images/2423.png
  1. Deslice hacia abajo a la sección Marco de cuadrícula y seleccione un estilo de marco que se ajuste a su gusto. También marque la caja Dibujar coordenadas.

../_images/2520.png
  1. Ajuste la Distancia a marco de mapa hasta que las coordenadas sean legibles. Cambie la Precisión de coordenada a 1 de manera que las coordenadas se muestren sólo hasta el primer decimal.

../_images/2618.png
  1. Ahora agregaremos una Flecha de Norte al mapa. La Composición de Impresión viene con una agradable colección de imágenes relacionadas con mapas - incluyendo varios tipos de Flechas de Norte. Clic en Diseño ‣ Añadir Imagen.

../_images/2718.png
  1. Manteniendo el botón izquierdo del ratón, dibuje un rectángulo en la esquina superior derecha del lienzo de mapa. En el panel de la derecha, clic en la pestaña Propiedades del Elemento y expanda la sección Buscar directorios y seleccione la imagen de Flecha de Norte de su gusto.

../_images/2816.png
  1. Ahora agregaremos una barra de escala. Clic en Diseño ‣ Añadir Barra de Escala.

../_images/2915.png
  1. Clic en el diseño donde quiere que aparezca la barra de escala. En la pestaña Propiedades de Elemento, asegúrese que ha elegido elemento correcto de mapa para el cual mostrar la barra de escala. Elija el Estilo que se ajusta a su requerimiento. En el panel Segmentos, puede ajustar el número de segmentos y su tamaño.

../_images/3013.png
  1. Es tiempo de etiquetar nuestro mapa. Clic en Diseño ‣ Añadir Etiqueta.

../_images/3116.png
  1. Clic en el mapa y dibuje una caja donde debería estar la etiqueta. En la pestaña Propiedades de Elemento, expanda la sección Etiqueta e ingrese el texto como se muestra abajo. También podemos ingresar el texto como HTML. Marque la casilla Representar como Html de manera que el diseñador interpretará las etiquetas HTML.

<div align=center>
<h1>Map of Japan</h1>
</div>
../_images/3213.png
  1. De forma similar agregue otra etiqueta para los créditos de datos y software.

../_images/3312.png
  1. Una vez que esté satisfecho con el mapa, puede exportarlo como Imagen, PDF o SVG. Para este tutorial, exportémoslo como una imagen. Clic en Diseño ‣ Exportar como Imagen.

../_images/3412.png
  1. Guarde la imagen en el formato de su preferencia. A continuación está la imagen PNG exportada.

../_images/3511.png
comments powered by Disqus