Analiza Punctelor dintr-un Poligon

Puterea GIS-ului constă în analiza simultană a surselor multiple de date. De multe ori, răspunsul pe care îl căutați, rezidă în mai multe straturi diferite, fiind nevoie de unele analize pentru extragerea și compilarea acestei informații. O astfel de analiză este Points-in-Polygon. Când aveți un strat poligonal și altul de tip punct - și vreți să aflați câte sau care dintre puncte se încadrează în granițele fiecărui poligon, puteți folosi această metodă de analiză.

Privire de ansamblu asupra activității

Fiind în posesia locațiilor tuturor cutremurelor semnificative cunoscute, vom încerca să aflăm care este țara cu cel mai mare număr de cutremure.

Obținerea datelor

Vom folosi NOAA’s National Geophysical Data Center’s Significant Earthquake Database ca strat al tuturor cutremurelor majore. Descărcați tab-delimited earthquake data.

Natural Earth deține setul de date Admin 0 - Countries. Descărcați countries

Pentru comoditate, puteți descărca o copie a setului de date, făcând clic pe link-ul următor:

signif.txt

ne_10m_admin_0_countries.zip

Surse de date: [NGDC] [NATURALEARTH]

Procedura

  1. Deschideți Layer ‣ Add Delimited Text Layer și navigați la fișierul descărcat signif.txt.

../_images/1106.png
  1. Deoarece acesta este un fișier delimitat prin tab-uri alegeți Tab pentru File format. X field și Y field se vor auto-popula. Clic pe OK.

Note

Puteți vedea unele mesaje de eroare, pe măsură ce QGIS încearcă să importe fișierul. Acestea sunt erori valide, iar câteva rânduri din fișier nu vor fi importate. Puteți ignora erorile, în interesul acestui tutorial.

../_images/258.png
  1. Deoarece setul de date al cutremurelor are coordonate Latitudine/Longitudine, alegeți WGS 84 EPSG:436 ca CRS, în fereastra de dialog Coordinate Reference System Selector.

../_images/334.png
  1. Stratul de tip punct al cutremurelor ar trebui să fie de-acum încărcat și afișat în QGIS. Să deschidem, de asemenea, stratul țărilor. Mergeți la Layer ‣ Add Vector Layer. Navigați la fișierul descărcat ne_10m_admin_0_countries.zip, apoi faceți clic pe Open. Selectați stratul ne_10m_admin_0_countries.shp, în fereastra de dialog Select layers to add....

../_images/424.png
  1. Clic pe Vector ‣ Analysis Tools ‣ Point in Polygon

../_images/525.png
  1. În fereastra tip pop-up, selectați stratul poligonal și, respectiv, stratul de tip punct. Denumiți stratul de ieșire ca earthquake_per_coutry.shp și faceți clic pe OK.

Note

Fiți răbdători după ce faceți clic pe OK; pot dura până la 10 minute până va încheia QGIS calculul.

  1. Când sunteți întrebați dacă doriți să adăugați stratul la Cuprins, faceți clic pe Yes.

../_images/722.png
  1. Veți vedea că un nou strat este adăugat la Cuprins. Deschideți tabela de atribute prin clic-dreapta pe strat și selectând Open Attribute Table.

../_images/821.png
  1. În tabela de atribute, veți observa un câmp nou, denumit PNTCNT. Acesta este numărul de puncte din stratul de cutremure care sunt în interiorul fiecărui poligon.

../_images/919.png
  1. Pentru a obține răspunsul, pur și simplu se poate sorta tabelul după câmpul PNTCNT, iar țara cu cel mai mare număr va constitui răspunsul nostru. Efectuând clic de 2 ori pe PNTCNT, coloana va fi sortată în ordine descrescătoare. Faceți clic pe primul rând pentru a o selecta, apoi închideți tabela de atribute.

../_images/1020.png
  1. Înapoi în fereastra principală QGIS, veți vedea o entitate evidențiată în galben. Aceasta este corelată cu rândul selectat din tabela de atribute, cu cel mai mare număr de puncte. Selectați instrumentul Identificare, apoi faceți clic pe acel poligon. Puteți vedea că țara cu cel mai mare număr de cutremure semnificative este China.

../_images/1123.png

Am determinat, din analiza simplă a 2 seturi de date, că cel mai mare număr de cutremure majore le-a avut China. Am putea rafina această analiză mai departe, prin luarea în considerare a populației și a mărimii țării, apoi să determinăm care este țara cea mai grav afectată de cutremurele majore.

comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License