Usare i Plugins

I plugins in QGIS sono utili integrazioni del software. Sono strumenti realizzati sia dagli sviluppatori di QGIS che da altri utenti indipendenti che intendono aumentare le funzionalità di base di questo software. I plugins vengono realizzati e messi a disposizione di tutti gli utenti di QGIS.

Descrizione del compito

In questa esercitazione apprenderete a installare Plugins Interni (Core Plugins) e Plugins esterni (External Plugins). Imparerete, inoltre, come individuare i plugins nel menu di QGIS dopo che sono stati installati.

Procedimento

Plugins interni

I plugins interni sono già parte della vostra installazione standard di QGIS. Per usarli è sufficiente lanciarli.

  1. Aprite QGIS. Fate click su Plugins ‣ Gestisci e Installa plugins.... per aprire la finestra di dialogo Gestore Plugin.

../_images/1135.png
  1. Anche se questa è la prima volta che avviate QGIS, potrete vedere molti plugin elencati nella tabella plugins installati . Si tratta, in effetti, di Plugins Interni (Core Plugins) che vengono caricati automaticamente nel corso dell’installazione di QGIS.

../_images/288.png
  1. Avviamo adesso uno dei plugins. Facciamo click sulla checkbox vicina a Plugin di interrogazione spaziale. Questo sarà sufficiente ad attivare il plugin e voi potrete usarlo. Una cosa da notare è che questo plugin ha la proprietà di inserire un menu in diverse posizioni di QGIS e di creare nuovi pannelli è nuove barre degli strumenti. In taluni di questi casi può essere difficoltoso capire come trovare gli strumenti che abbiamo appena attivato. Un metodo potrebbe essere quello di guardare nella descrizione dei plugin. Nel nostro caso la descrizione dice: Categoria: Vettore. Ciò significa che questo plugin, una volta attivato, si troverà sotto il menu a tendina Vettori. Click sul pulsante Close.

../_images/345.png
  1. Ora che il plugin Interrogazione spaziale è stato reso attivo, potete andare sul menu Vettore ‣ Interrogazione Spaziale per utilizzare le funzionalità appena aggiunte dal plugin.

../_images/432.png

Plugins Esterni

I plugins esterni sono scaricabili dal QGIS Plugins Repository e devono essere installati dall’utente prima di essere usati. Un metodo veloce per visualizzarli è quello di usare lo strumento Gestore Plugin .

  1. Aprite QGIS. Fate click su Plugins ‣ Gestisci e Installa plugins.... per aprire la finestra di dialogo Gestore Plugin.

../_images/533.png
  1. Fare click sulla tabella Altro . Qui troverete un elenco ordinato di plugins.

../_images/631.png
  1. Nell’ambito della nostra esercitazione troviamo e installiamo un plugin chiamato ‘QuickQKT’. Non appena inizierete a digitare qui nella casella di ricerca, vedrete il risultato. Fate click su QuickWKT. Poi fate click su Installa plugin per renderlo operativo.

../_images/730.png
  1. Una volta che il plugin è stato scaricato e installato comparirà una casella di dialogo per la conferma.

../_images/829.png
  1. Come potete notare, a differenza di quanto visto sopra, qui non viene fatta menzione della categoria nella descrizione. Questo rende molto difficile determinare come individuare il plugin che abbiamo appena installato. Il più delle volte i plugin esterni si troveranno menu Plugins di QGIS. Click su Plugins ‣ QuickWKT e vedrete il plugin appena installato. Normalmente, i plugin esterni creano anche un pulsante nella barra degli strumenti Plugins. Potete anche usare quel pulsante per accedere al plugin.

../_images/927.png

Plugins Sperimentali

Ora sapete come installare e trovare un Plugin Esterno in QGIS. Vediamo ora di esplorare alcune opzioni più avanzate. In alcune occasioni cerchiamo uno plugin specifico, ma non lo troviamo nella scheda Altro. La spiegazione potrebbe essere che il plugin è classificato come Sperimentale. Qui vedrete come installare plugins sperimentali

  1. Aprite Gestore Plugin da Plugin . Plugins ‣ Gestisci e installa plugins... Click sulla casella a sinistra sotto la voce Impostazioni . Vedrete anche un’opzione Mostra i plugins sperimentali. Fate click sulla relativa checkbox per rendere l’opzione operativa.

../_images/1028.png
  1. Vedrete una nuova scheda a sinistra chiamata Nuovo. I plugins sperimentali recenti si troveranno qui sotto.

Nota

La scheda Nuovo apparirà solo temporaneamente dopo che avete abilitato dei plugins sperimentali. La prossima volta che aprirete Gestore plugin i plugins sperimentali verranno presentati come plugins esterni sotto la scheda Altro.

../_images/1136.png
  1. Installiamo il plugin chiamato TimeManager. Click sul nome del plugin e poi Click su Installa.

../_images/1229.png
  1. Ora, quando tornerete alla finestra principale di QGIS, vedrete un nuovo pannello alla base della finestra. Questo pannello è stato creato dal TimeManager plugin. Questa è un’altra delle modalità attraverso le quali i plugin possono aggiungere funzionalità all’interfaccia utente.

../_images/1326.png
  1. D’ora in poi potrete attivare/disattivare questo panello da Visualizza ‣ Pannello ‣ Time Manager.

../_images/1425.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License