Mosaici e operazioni di ritaglio con i layer raster

Questa esercitazione esplora alcune operazioni di base in QGIS con i file raster, come la visualizzazione, la composizione di mosaici e la creazione di sottoinsiemi.

Descrizione del compito

Scaricheremo alcuni dati raster di pubblico dominio che descrivono il territorio del Brasile e li esamineremo in QGIS. Poi, uniremo queste foto in una sorta di mosaico e, infine, le ritaglieremo usando i confini amministrativi del paese per ricavare un unico dataset del Brasile abbastanza verosimile.

Altri aspetti che avremo modo di apprendere nel corso dell’esercizio.

  • Searcing and downloading near real-time public domain satellite imagery.
  • Selecting a single feature from a vector layer and saving it to a new shapefile.

Ottenere i dati necessari.

Intanto, per ritagliare il nostro raster, ci occorrono i confini del Brasile. Potete scaricare lo shapefile Admin 0 - Countries da Natural Earth.

Il sito NASA/GSFC, Rapid Response site dispone di una buona collezione di immagini prodotte in tempo quasi reale. Un ottimo lavoro a carattere locale è USDA Foreign Agricultural Service (FAS) subsets... Nell’ambito di questo esercizio utilizzeremo una risoluzione di 2km dal FAS subset del Brasile.

Di seguito spieghiamo in dettaglio come cercare e scaricare i dati di nostro interesse.

  1. Aprite South America region subsets.. Trovate il sottoinsieme di foto che si chiama Brasile visibile nella sezione FAS Subsets. Fate click su alcune di esse.

../_images/1109.png
  1. Nella pagina dettagli fate click sul link 2km che si trova al di sotto dell’immagine che avete scelto. Qui scaricheremo il prodotto NDVI. Qui sono disponibili ulteriori informazioni su NDVI.

../_images/268.png
  1. Fare click sul link Download GeoTIFF file per scaricare l’immagine raster.

../_images/337.png

Ripetere la stessa operazione per tutti i 7 successivi sottinsiemi FAS del Brasile.

For convenience, you can directly download sample data used in this tutorial from links below.

ne_10m_admin_0_countries.zip

FAS_Brazil1.2013363.aqua.ndvi.2km.tif

FAS_Brazil2.2013363.terra.ndvi.2km.tif

FAS_Brazil3.2013363.aqua.ndvi.2km.tif

FAS_Brazil4.2013363.aqua.ndvi.2km.tif

FAS_Brazil5.2013363.aqua.ndvi.2km.tif

FAS_Brazil6.2013363.terra.ndvi.2km.tif

FAS_Brazil7.2013363.aqua.ndvi.2km.tif

Fonte Dati: [LANCE] [NATURALEARTH]

Procedimento

  1. Aprite QGIS e andate su Layer ‣ Aggiungi raster. ..

../_images/427.png
  1. Selezionate la cartella che contiene le singole immagini. Tenete premuto il pulsante della tastiera Ctrl e fate click con il mouse sui file di immagine per ottenere una selezione multipla. Click su Apri.

../_images/528.png
  1. Vedrete le immagini caricate alla vostra sinistra, nella Tabella dei Contenuti (TOC). Ora, andremo a compilare una singola immagine Mosaico ricavata dall’unione delle immagini che abbiamo scaricato. Fate click su Raster ‣ Miscellanea ‣ Unione.

Nota

Il menu raster di QGIS proviene da un plugin interno chiamato GdalTools. Se a qualcuno dovesse mancare il menu Raster, attivate il plugin GdalTools da Plugins ‣ Gestisci e installa plugin ‣ Installa. Se avete bisogno di ulteriori dettagli sui plugin, potete dare un’occhiata a Usare i Plugins

../_images/626.png
  1. Nella finestra di dialogo Unione , fate click sul tasto Scegli... vicino a File di input . Quindi, selezionate dalla loro directory tutte le singole immagini geotiff mantenendo premuto il tasto Ctrl della tastiera e facendo click su ciascuna di esse. Ora, fate click sul tasto Scegli... vicino a File di output. Date al file di output il nome di Brazil_mosaic.tif. Poi, in basso, cliccate la casella Carica sulla mappa quando finito. Click su OK.

../_images/725.png
  1. Quando l’immagine mosaico sarà stata creata e caricata nella finestra principale riceverete in una finestra di pop-up il messaggio Processo Completato . Come potete vedere, le singole immagini sono ora combinate e “mosaicizzate” in un singolo layer. Potete spegnere i layer delle singole immagini deselezionando le rispettive check box nella TOC.

../_images/824.png
  1. Un’altra classica operazione con il Raster che possiamo realizzare è quella di riassemblare o ritagliare un’immagine. Possiamo usare un poligono di un layer vettoriale per adattare il raster alla sua forma esatta. Iniziamo caricando lo shapefile poligonale delle nazioni che abbiamo scaricato da Natural Earth. Go to Layer ‣ Aggiungi Vettore....

../_images/922.png
  1. Selezionate il ne_10m_admin_0_countries.zip e fate click su Apri. Quando comparirà la finestra di dialogo per selezionare il layer all’interno dello zip file, selezionate ne_10m_admin_0_countries.shp. (Al variare dei sistemi operativi e delle versioni di QGIS potrebbero darsi rari casi in cui è necessario estrarre e aprire i file zip in modo tradizionale. N.d.T).

../_images/1023.png
  1. Adesso che il vettore è stato caricato occupiamoci di selezionare ed estrarre il poligono del Brasile. Selezionate lo strumento Seleziona singolo elemento dalla barra degli strumenti.

../_images/1126.png
  1. Cliccate in qualsiasi punto del poligono del Brasile ed esso verrà selezionato.

../_images/1224.png
  1. Click con il tasto destro sul ne_10m_admin_0_countries e scegliere Salva la Selezione con nome....

../_images/1321.png
  1. Chiamate il vostro output brazil_boundary.shp e assicuratevi che l’opzione Aggiungi il file salvato sulla mappa sia attiva. Click su OK.

../_images/1420.png
  1. Vedrete ora nella finestra di QGIS il poligono dei confini amministrativi del Brasile.

../_images/1519.png
  1. Ora andate su Raster ‣ Estrazione ‣ Clipper.

../_images/1618.png
  1. Scegliete come file di input (raster) il file Brazil_mosaic. Chiamate il File di Output con il nome di Brazil_mosaic_clipped.. Nella sezione Modi di clip della finestra, selezionate Strato per la Maschera. Selezionate il file appena creato brazil_boundary come strato per la maschera. Selezionate infine l’opzione Carica sulla mappa quando finito. Click su OK.

../_images/1717.png
  1. Il layer appena ritagliato sarà caricato in QGIS, come potete notare i pixel neri circondano la nostra immagine. Togliamoli. Click sul tasto destro sul layer Brazil_mosaic_clipped e selezionate Proprietà.

../_images/1817.png
  1. Andate sulla scheda Trasparenza e aggiungete 0 nella casella Valori nulli aggiuntivi.

../_images/1915.png
  1. Ora avete a disposizione una bella immagine mosaicizzata e ritagliata sui confini del paese. Potrete utilizzarla nei vostri progetti come un layer di sfondo oppure per ricavarne ulteriori analisi.

../_images/2012.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License