Работа с цифровой моделью рельефа

Данные рельефа, или высот, бывают полезны для многих видов геоинформационного анализа, а также часто используются в картах. В QGIS встроены обширные возможности для обработки данных высот. В этом уроке мы по шагам пройдем процесс создания из данных высот таких производных, как горизонтали, теневая отмывка и т.д.

Обзор задачи

Нужно создать карту с изолиниями и теневой отмывкой для окрестности горы Эверест.

Вы научитесь также

  • искать и загружать бесплатно доступные пространственные данные;

  • экспортировать векторный слой в формат KML и просматривать в Google Earth.

Получение данных

Мы будем работать с набором данных GMTED2010 от Геологической службы США. Эти данные могут быть загружены с сайта USGS Earthexplorer. GMTED (Global Multi-resolution Terrain Elevation Data) - это глобальный набор данных о рельефе, который является новой версией набора данных GTOPO30.

Как искать и загружать релевантные данные с сайта USGS Earthexplorer:

  1. Зайдите на сайт USGS Earthexplorer . На вкладке :guilabel: Search Criteria, введите в строку поиска Mt. Everest. Нажмите на результат поиска, чтобы выбрать место.

../_images/1144.png
  1. На вкладке Data Sets разверните группу Digital Elevation и выберите GMTED2010.

../_images/2100.png
  1. Теперь вы можете перейти ко вкладке Results и увидеть часть набора данных, удовлетворяющую критериям поиска. Нажмите кнопку Download Options. Теперь вам нужно будет авторизоваться. Вы можете создать бесплатную учетную запись, если ее у вас нет.

../_images/350.png
  1. Выберите опцию 30 ARC SEC и нажмите Select Download Option.

../_images/437.png

Теперь у вас есть файл с именем GMTED2010N10E060_300.zip. Данные высот распространяются в различных растровых форматах, таких как ASC, BIL, GeoTiff и т.д. QGIS поддерживает широкий спектр растровых форматов через библиотеку GDAL. Данные GMTED поставляются в виде файлов GeoTiff, содержащихся zip-архиве.

Для удобства вы можете загрузить копию данных напрямую по приведенной ниже ссылке:

GMTED2010N10E060_300.zip

Источник данных: [GMTED2010]

Методика

  1. Откройте меню Layer ‣ Add Raster Layer и найдите загруженный zip-файл.

../_images/538.png
  1. В нем содержится много различных файлов, сгенерированных по различным алгоритмам. Для этого урока мы будем использовать файл с именем 10n060e_20101117_gmted_mea300.tif.

../_images/636.png
  1. Вы увидите данные рельефа, отрисованные на карте QGIS. Каждый пиксель растра рельефа характеризует среднюю высоту в метрах в этой точке. Чем светлее пиксель, тем большую высоту он представляет.

../_images/735.png
  1. Let’s find our area of interest. From Wikipedia, we find that the coordinates for our area of interest - Mt. Everest - is located at the coordinates 27.9881° N, 86.9253° E. Note that QGIS uses the coordinates in (X,Y) format , so you must use the coordinates as (Longitude, Latitude). Paste 86.9253,27.9881 these at the bottom of QGIS window where it says Coordinate and press Enter. The viewport will be centered at this coordinate. To zoom in, Enter 1:1000000 in the Scale field and press Enter. You will see the viewport zoom to the area around the Himalayas.
../_images/834.png
  1. We will now crop the raster to this area of interest. Select the Clipper tool from Raster ‣ Extraction ‣ Clipper.

Примечание

The Raster menu in QGIS comes from a core plugin called GdalTools. If you do not see the Raster menu, enable the GdalTools plugin from Plugins ‣ Manage and install plugins ‣ Installed. See Использование модулей расширения for more details.

../_images/932.png
  1. In the Clipper window, name your output file as everest_gmted30.tif. Select the Clipping mode as Extent.
../_images/1033.png
  1. Keep the Clipper window open and switch to the main QGIS window. Hold your left mouse button and draw a rectangle covering the full canvas.
../_images/1145.png
  1. Now back in the Clipper window, you will see the coordinates auto-populated from your selection. Make sure the Load into canvas when finished option is checked, and click OK.
../_images/1233.png
  1. Once the process finishes, you will see a new layer loaded in QGIS. This layer covers only the area around Mt. Everest.Now we are ready to generate contours. Select the contour tool from Raster ‣ Extraction ‣ Contour.
../_images/1330.png
  1. In the Contour dialog, select everest_gmted30 as the Input file. Name the Output file for contour lines as everest_countours.shp. We will generate contour lines for 100m intervals, so put 100 as the Interval between contour lines. Also check the Attribute name option so elevation value will be recorded as attribute of each contour line. Click OK.
../_images/1429.png
  1. Once the processing is complete, you will see contour lines loaded into the canvas. Each line in this layer represents a particular elevation. All points along a countour line in the underlying raster would be at the same elevation. The closer the lines, the steeper the slope. Let’s inspect the contours a bit more. Right click on the contours layer and choose Open Attribute Table.
../_images/1527.png
  1. You will see that each line feature has an attribute named ELEV. This is the height in metres that each line represents. Click on the column header a couple of times to sort the values in descending order. Here you will find the line representing the highest elevation in our data, i.e. Mt. Everest.
../_images/1626.png
  1. Select the top row, and click on the Zoom to selection button.
../_images/1724.png
  1. Switch to the main QGIS window. You will see the selected contour line highlighted in yellow. This is the area of the highest elevation in our dataset.
../_images/1824.png
  1. Now let us create a hillshade map from the raster. Select Raster ‣ Analysis ‣ DEM (Terrain Models).
../_images/1922.png
  1. In the DEM (Terrain Models) dialog, choose everest_gmted30 as the Input file. Name the Output file as everest_hillshade.tif. Choose Hillshade as the Mode. Leave all other options as is. Make sure the Load into canvas when finished option is checked, and click OK.
../_images/2019.png
  1. Once the process finishes, you will see yet another raster loaded into QGIS canvas. Since you maybe zoomed-in near the Mt.Everest region, right click on the everest_hillshade layer and choose Zoom to Layer Extent.
../_images/2123.png
  1. Now you will see the full extent of the hillshade raster.
../_images/2222.png
  1. Вы также можете визуализировать слой горизонталей и проверить свой анализ, экспортировав слой в формат KML и загрузив его в Google Earth. Щелкните правой кнопкой мыши на слое горизонталей, выберите Save as...

../_images/2318.png
  1. Выберите Keyhole Markup Language [KML] в строке Format. Назовите результирующий файл contours.kml и нажмите OK.

../_images/2416.png
  1. Перейдите к файлу с результатом на вашем диске и двойным кликом откройте его в Google Earth.

../_images/2515.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License