Анализ количества точек в полигонах

Мощь ГИС заключается в совместном анализе нескольких источников данных. Зачастую, ответ, который вы ищете, лежит в разных слоях, и вы должны произвести какой-то анализ, чтобы извлечь и обобщить данную информацию. Одним из таких видов анализа является Points-in-Polygon. Если у вас есть полигональный слой и точечный слой, и вы хотите знать, как много или какие именно точки попадают в каждый полигон, вы можете использовать этот метод анализа.

Обзор задачи

Учитывая расположение всех известных значимых землетрясений, мы постараемся выяснить, в какой стране было больше всего землетрясений.

Получение данных

We will use NOAA’s National Geophysical Data Center’s Significant Earthquake Database as our layer represenging all major earthquakes. Download the tab-delimited earthquake data.

Natural Earth has Admin 0 - Countries dataset. Download the countries

For convenience, you may directly download a copy of the dataset from the link below:

signif.txt

ne_10m_admin_0_countries.zip

Источники данных: [NGDC] [NATURALEARTH]

Методика

  1. Open Layer ‣ Add Delimited Text Layer and browse to the downloaded signif.txt file.
../_images/1106.png
  1. Since this is a tab-delimited file, choose Tab as the File format. The X field and Y field would be auto-populated. Click OK.

Примечание

You may see some error messages as QGIS tries to import the file. These are valid errors and some rows from the file will not be imported. You can ignore the errors for the purpose of this tutorial.

../_images/258.png
  1. As the earthquake dataset has Latitude/Longitude coordinates, choose WGS 84 EPSG:436 as the CRS in the Coordinate Reference System Selector dialog.
../_images/334.png
  1. The earthquake point layer would now be loaded and displayed in QGIS. Let’s also open the Countries layer. Go to Layer ‣ Add Vector Layer. Browse to the downloaded ne_10m_admin_0_countries.zip file and click Open. Select the ne_10m_admin_0_countries.shp as the layer in the Select layers to add... dialog.
../_images/424.png
  1. Click on Vector ‣ Analysis Tools ‣ Point in Polygon
../_images/525.png
  1. In the pop-up window, select the polygon layer and point layer respectively. Name the output layer as earthquake_per_coutry.shp and Click OK.

Примечание

Be patient after clicking OK, QGIS may take upto 10 minutes to calculate the results.

  1. When asked whether you want to add the layer to TOC, click Yes.
../_images/722.png
  1. You will see a new layer is added to the table of content. Open the attribute table by right-clicking on the layer and selecting Open Attribute Table.
../_images/821.png
  1. In the attribute table, you will notice a new field named PNTCNT. This is the count of number of points from the earthquakes layer that fall within each polygon.
../_images/919.png
  1. To get our answer, we can simply sort the table by PNTCNT field and the country with highest count will be our answer. Click 2-times on the PNTCNT column to get it sorted in descending order. Click on the first row to select it and close the Attribute Table.
../_images/1020.png
  1. Back in the main QGIS window, you will see one feature highlighted in yellow. This is the feature linked to the selected row in the attribute table which had the highest number of points. Select the Identify tool and click on that polygon. You can see that the country with the highest number of Significant earthquakes is China.
../_images/1123.png

We determined from the simple analysis of 2 datasets that China has had the highest number of major earthquakes. You may refine this analysis further by taking into consideration the population as well as the size of the country and determine which is the most adversely affected country by major earthquakes.

comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License