Δημιουργία Μωσαϊκού και Περικοπής σε Πλέγμα

Αυτό το tutorial διερευνά κάποιες βασικές λειτουργίες πλέγματος στο QGIS όπως η προβολή,η δημιουργία μωσαϊκού και η δημιουργία υποσυνόλων.

Επισκόπηση εργασίας

Θα κατεβάσετε κάποια δεδομένα πλέγματος δημοσίου τομέα για τη Βραζιλία και δείτε τα στο QGIS. Στη συνέχεια,θα τα συγχωνεύσουμε σε ένα ενιαίο μωσαϊκό και θα το περικόψουμε χρησιμοποιώντας τα σύνορα της χώρας για να πάρουμε ένα ενιαίο συνεχόμενο σύνολο δεδομένων για τη χώρα.

Άλλες δεξιότητες που θα μάθετε

  • Αναζητώντας και κατεβάζοντας σε σχεδόν πραγματικό χρόνο δορυφορικές εικόνες του δημόσιου τομέα .

  • Επιλέγοντας ένα συγκεκριμένο χαρακτηριστικό από ένα διανυσματικό επίπεδο και αποθηκεύοντας το σε ένα shapefile.

Πάρτε τα δεδομένα

Χρειαζόμαστε τα σύνορα της χώρας της Βραζιλίας για να περικόψουμε το πλέγμα μας.Μπορείτε να τα πάρετε από το shapefile Admin 0 - Countries από το Natural Earth.

NASA / GSFC, Η ιστοσελίδα Rapid Response <https://earthdata.nasa.gov/data/near-real-time-data/rapid-response/modis-subsets>`_ έχει μια καλή συλλογή από δορυφορικές εικόνες σχεδόν πραγματικό χρόνο. Ένα καλό περιφερειακό προϊόν είναι το USDA Foreign Agricultural Service (FAS) subsets.. Θα χρησιμοποιήσουμε ανάλυση 2χλμ. και FAS υποσύνολα για τη Βραζιλία για αυτό το tutorial.

Εδώ είναι το πως θα αναζητήσετε και θα κατεβάσετε τα σχετικά δεδομένα.

  1. Ανοίξτε το South America region subsets. Βρείτε τα υποσύνολα της Βραζιλίας που εμφανίζονται στο τμήμα FAS Subsets.Κάντε κλικ σε οποιοδήποτε από αυτά.

../_images/1109.png
  1. Στη σελίδα με τις λεπτομέρειες,κάντε κλικ στο σύνδεσμο 2km κάτω από το προϊόν της επιλογής σας.Εδώ θα κατεβάσετε το προϊόν 2km .Μάθετε περισσότερα σχετικά με το NDVI στο <http://en.wikipedia.org/wiki/Normalized_Difference_Vegetation_Index>`_.

../_images/268.png
  1. Κάντε κλικ στο σύνδεσμο Download GeoTIFF file για να κατεβάσετε την εικόνα πλέγματος.

../_images/337.png

Επαναλάβετε τη διαδικασία για όλα τα 7 FAS υποσύνολα της Βραζιλίας.

Για ευκολία, μπορείτε να μεταφορτώσετε απευθείας ένα δείγμα από τα δεδομένα που θα χρησιμοποιήσουμε σε αυτή την άσκηση από τις παρακάτω συνδέσεις.

ne_10m_admin_0_countries.zip

FAS_Brazil1.2013363.aqua.ndvi.2km.tif

FAS_Brazil2.2013363.terra.ndvi.2km.tif

FAS_Brazil3.2013363.aqua.ndvi.2km.tif

FAS_Brazil4.2013363.aqua.ndvi.2km.tif

FAS_Brazil5.2013363.aqua.ndvi.2km.tif

FAS_Brazil6.2013363.terra.ndvi.2km.tif

FAS_Brazil7.2013363.aqua.ndvi.2km.tif

Πηγές δεδομένων: [NGDC] [NATURALEARTH]

Διαδικασία

  1. Ανοίξτε το QGIS και πηγαίνετε στο Layer ‣ Add Raster Layer...

../_images/427.png
  1. Περιηγηθείτε στον κατάλογο με τις μεμονωμένες εικόνες. Κρατήστε πατημένο το : kbd: Ctrl και κάντε κλικ στα αρχεία εικόνας για να κάνετε πολλαπλή επιλογή. Κάντε κλικ στο: guilabel: Open.

../_images/528.png
  1. Θα δείτε τις εικόνες να φορτώνουν στον πίνακα περιεχομένων στην αριστερή πλευρά. Τώρα, ας δημιουργήσουμε μια ενιαία εικόνα Mosaic μέσα από όλες αυτές τις μεμονωμένες εικόνες. Κάντε κλικ στο: menuselection: Raster -> Miscellaneous -> Merge.

Note

Στο μενού : guilabel: Raster στο QGIS προέρχεται από έναν κεντρικό πρόσθετο που ονομάζεται: guilabel:` GdalTools`. Εάν δεν μπορείτε να δείτε το μενού : guilabel: Raster, ενεργοποιήστε το πρόσθετο : guilabel:` GdalTools` από Plugins ‣ Manage and install plugins ‣ Installed. Δείτε το : doc: using_plugins για περισσότερες λεπτομέρειες.

../_images/626.png
  1. Στο παράθυρο διαλόγου Merge,κάντε κλικ στο Select... δίπλα στο Input files και αναζητήστε τον κατάλογο που περιέχει όλα τα μεμονωμένα geotiffs.Κρατήστε πατημένο το Ctrl και επιλέξτε όλα τα υποσύνολα.Τώρα κάντε κλικ στο Select... δίπλα στο Output file και ονομάστε την έξοδο ως Brazil_mosaic.tif. Κάτω,τσεκάρετε το κουτάκι δίπλα στο Load into canvas when finished. Κάντε κλικ στο OK.

../_images/725.png
  1. Θα δείτε ένα αναδυόμενο μήνυμα που λέει Processing complete,όταν το μωσαϊκό έχει δημιουργηθεί και έχει φορτώσει στον καμβά του QGIS . Θα δείτε ότι οι μεμονωμένες εικόνες έχουν συνδυαστεί και έχουν γίνει ένα μωσαϊκό σε ένα μόνο επίπεδο.Τώρα μπορείτε να απενεργοποιήσετε τα μεμονωμένα επίπεδα αποεπιλέγοντας το κουτάκι δίπλα τους.

../_images/824.png
  1. Μια ακόμη λειτουργία πλέγματος που μπορείτε να κάνετε είναι να δημιουργήσετε υποσύνολα ή να ‘κόψετε’ μια εικόνα.Μπορούμε να χρησιμοποιήσουμε ένα πολύγωνο από ένα διανυσματικό επίπεδο για να κόψουμε το πλέγμα στο ακριβές σχήμα.Ας φορτώσουμε το shapefile των πολυγώνων της χώρας που έχουμε κατεβάσει από το Natural Earth.Πηγαίνετε στο Layer ‣ Add Vector Layer.

../_images/922.png
  1. Επιλέξτε το αρχείο ne_10m_admin_0_countries.zip και κάντε κλικ στο Open. Όταν σας ζητηθεί,επιλέξτε το επίπεδο που βρίσκεται στο αρχείο zip,επιλέξτε το ne_10m_admin_0_countries.shp.

../_images/1023.png
  1. Αφού φορτώσει το διανυσματικό επίπεδο,θέλουμε να επιλέξουμε και να εξάγουμε το πολύγωνο της Βραζιλίας.Επιλέξτε το εργαλείο Select Single Feature από τη γραμμή εργαλείων.

../_images/1126.png
  1. Κάντε κλικ οπουδήποτε στο πολύγωνο της Βραζιλίας και αυτό θα επιλεγεί.

../_images/1224.png
  1. Κάντε δεξί-κλικ στο επίπεδο ne_10m_admin_0_countries και επιλέξτε Save Selection As....

../_images/1321.png
  1. Ονομάστε την έξοδό σας ως brazil_boundary.shp και βεβαιωθείτε ότι είναι τσεκαρισμένο το κουτάκι Add saved file to map.Κάντε κλικ στο OK.

../_images/1420.png
  1. Θα δείτε ότι το πολύγωνο με τα σύνορα της Βραζιλίας έχει φορτώσει στο QGIS.

../_images/1519.png
  1. Τώρα πηγαίνετε στο Raster ‣ Extraction ‣ Clipper.

../_images/1618.png
  1. Επιλέξτε το input file (raster) ως Brazil_mosaic. Ονομάστε το Output file ως Brazil_mosaic_clipped.Στο τμήμα Clipping mode ,επιλέξτε Mask layer.Επιλέξτε το brazil_boundary που δημιουργήθηκε πρόσφατα ως το επίπεδο μάσκας.Τσεκάρετε το κουτάκι δίπλα στο Load into canvas when finished.Κάντε κλικ στο OK.

../_images/1717.png
  1. Το νέο κομμένο επίπεδο θα φορτώσει στο QGIS.Θα παρατηρήσετε τα μαύρα pixels γύρω από το πραγματικό μωσαϊκό.Ας τα αφαιρέσουμε.Κάντε δεξί κλικ στο επίπεδο Brazil_mosaic_clipped και επιλέξτε : guilabel: Properties.

../_images/1817.png
  1. Πηγαίνετε στην καρτέλα Transparency και προσθέστε 0` ως Additional no data value.

../_images/1915.png
  1. Τώρα έχετε ένα ωραίο μωσαϊκό που έχει κοπεί στα σύνορα της χώρας,το οποίο μπορείτε να χρησιμοποιήσετε στο έργο σας ως ένα επίπεδο φόντου ή να κάνετε περαιτέρω ανάλυση σε αυτό.

../_images/2012.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License