Φτιάχνοντας ένα χάρτη (QGIS3)

Συχνά χρειάζεται να δημιουργήσουμε ένα χάρτη που θα μπορεί να εκτυπωθεί ή να δημοσιευθεί. Το QGIS διαθέτει ένα ισχυρό εργαλείο που ονομάζεται Διάταξη εκτύπωσης που σας επιτρέπει να συγκεντρώσετε τα επίπεδα GIS και να τα ομαδοποιήσετε δημιουργώνταας χάρτες.

Επισκόπηση της διαδικασίας

Αυτός ο οδηγός θα σας δείξει πώς να δημιουργήσετε έναν χάρτη της Ιαπωνίας χρησιμοποιώντας πρότυπα στοιχεία χάρτου όπως ένθεση χάρτη, πλέγματα, βέλος βορά, γραμμή κλίμακας και ετικέτες.

Άλλες δεξιότητες που θα αποκτήσετε

  • Πώς να προβάλλετε και να αλλάξετε τις Μεταβλητές Έργου QGIS

  • Πώς να χρησιμοποιήσετε τις εκφράσεις QGIS

Λάβετε τα δεδομένα

Θα χρησιμοποιήσουμε τα πακέτα δεδομένων της Natural Earth Data - ειδικότερα, το Natural Earth Quick Start Kit που συνοδεύεται από παγκόσμια επίπεδα με όμορφα στυλ που μπορούν να φορτωθούν απευθείας στο QGIS.

Κατεβάστε το αρχείο Natural Earth Quickstart Kit.

Data Source [NATURALEARTH]

Διαδικασία

  1. Κατεβάστε και αποσυμπιέστε τα δεδομένα του πακέτου Natural Earth Quick Start Kit. Ανοίξτε το QGIS. Εντοπίστε τον κατάλογο Natural Earth quick start από τον πίνακα Browser. Ανοίξτε τον κατάλογο για να εντοπίσετε το έργο Natural_Earth_quick_start_for_QGIS_v3. Αυτό είναι το αρχείο έργου που περιέχει στυλιζαρισμένα επίπεδα σε μορφή QGIS Document. Διπλοπατήστε στο έργο για να το ανοίξετε.

../../_images/159.png
  1. Θα παρατηρήσετε ότι ο χάρτης περιέχει ετικέτες στα Ελληνικά. Το έργο αυτό χρησιμοποιεί μεταβλητές για να ορίσει την γλώσα. Μπορούμε να αλλάξουμε τις μεταβλητές ανοίγοντας το μενού Project ‣ Properties.

../../_images/230.png

Note

Οι μεταβλητές έργου (ή εργασίας) είναι ένας σπουδαίος τρόπος να αποθηκεύετε τιμές που αφορούν σε ένα συγκεκριμένο έργο ώστε αυτές να χρησιμοποιηθούν οπουδήποτε χρησιμοποιούνται εκφράσεις QGIS. Το έργο Natural_Earth_quick_start_for_QGIS_v3 συνοδεύεται από πολλές προρυθμισμένες μεταβλητές οι οποίες χρησιμοποιούνται για να παράγονται στυλ μέσα στο έργο αυτό.

  1. Ανοίξτε το φάκελο Variables του διαλόγου Project Properties. Εντοπίστε την μεταβλητή project_language και πατήστε στην στήλη Value για επεξεργαστείτε την τιμή της. Αλλάξτε την γλώσσα σε name_en και πατήστε OK.

../../_images/325.png
  1. Στο αρχικό παράθυρο του QGIS πατήστε το κουμπί Ανανέωση της Εργαλειοθήκη πλοήγησης χάρτη. Θα δείτε ότι ο χάρτης παίρνει Αγγλικές επιγραφές.

../../_images/412.png
  1. Χρησιμοποιείστε τα εργαλεία ελέγχου μετακίνησης και μεγέθυνσης της Εργαλειοθήκης πλοήγησης χάρτη για να μεγεθύνετε την Ιαπωνία.

../../_images/512.png
  1. Μπορείτε να απενεργοποιήσετε κάποια επίπεδα για δεδομένα τα οποία δεν χρειαζόμαστε για τον χάρτη αυτό. Επεκτείνετε τον κατάλογο z5 - 1:18m και αποεπιλέξτε το τετράγωνο δίπλα στα επίπεδα ne_10m_geography_marine_polys και ne_10m_admin_0_disputed_areas. Πριν κατασκευάσουμε ένα χάρτη κατάλληλο για εκτύπωση πρέπει να επιλέξουμε μια κατάλληλη προβολή. Το αρχικό CRS για το έργο μας είναι ρυθμισμένο σε EPSG:3857 Pseudo-Mercator. Το CRS αυτό είναι δημοφιλές για χαρτογράφηση στον Παγκόσμιο Ιστό και αποτελεί καλή επιλογή για τους σκοπούς μας ώστε μπορούμε να το αφήσουμε στην αρχική του τιμή. Ανοίξτε το μενού Εργασία ‣ Νέα διάταξη εκτύπωσης.

../../_images/612.png

Note

Για την Ιαπωνία το Κοινό Ορθογώνιο Σύστημα Συντεταγμένων Ιαπωνίας είναι ένα σύστημα αναφοράς συντεταγμένων (CRS) σχεδιασμένο ώστε να ελαχιστοποιεί τις παραμορφώσεις. Διαιρείται σε 18 ζώνες και αν εργάζεστε για κάποια μικρότερη περιοχή της Ιαπωνίας η χρήση του CRS είναι καλύτερη.

  1. Θα σας ζητηθεί να εισάγετε έναν τίτλο για την διάταξη Μπορείτε να τον αφήσετε κενό και να πατήσετε Ok.

../../_images/711.png

Note

Αφήνοντας το όνομα της διάταξης κενό θα αποδοθεί αυτόματα ένα αρχικό όνομα, για παράδειγμα Layout 1.

  1. Στο παράθυρο Διάταξη εκτύπωσης πατήστε στο κουμπί Πλήρης Μεγέθυνση για να προβάλλετε την Διάταξη σε πλήρη έκταση.

../../_images/811.png
  1. Τώρα πρέπει να φέρουμε στην διάταξη εκτύπωσης τον χάρτη που βλέπουμε στον καμβά του QGIS. Πηγαίνετε στο μενού Προσθήκη στοιχείου ‣ Προσθήκη χάρτη.

../../_images/911.png
  1. Μόλις η λειτουργία Προσθήκη χάρτη ενεργοποιηθεί, κρατήστε πατημένο το αριστερό πλήκτρο του ποντικιού και σύρετε ένα παραλληλόγραμμο μέσα στο οποίο θέλετε να εισάγετε τον χάρτη.

../../_images/1011.png
  1. Θα δείτε ότι το παραλληλόγραμμο παράθυρο θα γεμίσει με τον χάρτη από τον κύριο καμβά του QGIS. Ο παραγομενος χάρτης ίσως δεν καλύπτει πλήρως την επιφάνεια που μας ενδιαφέρει.. Χρησιμοποιείστε τις επιλογές Επεξεργασία ‣ Επιλογή/Μετακίνηση στοιχείου και Επεξεργασία ‣ Μετακίνηση περιεχομένου για να μετακινηθείτε μέσα στον χάρτη και να το κεντράρετε μέσα στο πρόγραμμα επεξεργασίας.

../../_images/1115.png
  1. Ας ρυθμίσουμε επίσης το επίπεδο μεγέθυνσης για τον χάρτη. Πατήστε στον φάκελο Ιδιότητες στοιχείου, στα δεξιά και εισάγετε τον αριθμό 10000000 ως τιμή για την Κλίμακα.

../../_images/1212.png
  1. Τώρα θα προσθέσουμε ένα ένθετο στοιχείο χάρτη που δείχνει μια μεγεθυμένη άποψη της περιοχής του Τόκυο. Πριν κάνουμε οποιαδήποτε αλλαγή στο κύριο παράθυρο του QGIS ελέγξτε τα τετραγωνίδια Κλείδωμα επιπέδων και Κλείδωμα των στυλ για τα επίπεδα. Αυτό θα διασφαλίσει ότι αν απενεργοποιήσουμε κάποια επίπεδα ή μεταβάλουμε τα στυλ τους, η προβολή μας δεν θα αλλάξει.

../../_images/1312.png
  1. Μεταβείτε στο κυρίως παράθυρο του QGIS. Απενεργοποιείστε την ομάδα επιπέδων z5 - 1:18m και ενεργοποιείστε την ομάδα z7 - 1: 4m. Το επίπεδο αυτό διαθέτει στυλ που είναι πιο κατάλληλα για μια μεγεθυμένη προβολή. Χρησιμοποιείστε τους ελέγχους μετακίνησης και μεγέθυνσης από την Εργαλειοθήκη πλοήγησης χάρτη και μεγεθύνετε την περιοχή γύρω από το Τοκυο.

../../_images/1410.png
  1. Είμαστε τώρα έτοιμοι να προσθέσουμε το ένθετο χάρτη. Μεταβείτε στο παράθυρο Διάταξη εκτύπωσης. Πηγαίνετε στο μενού Προσθήκη στοιχείου ‣ Προσθήκη χάρτη.

../../_images/1510.png
  1. Σχεδιάστε ένα παραλληλόγραμμο εκεί όπου θέλετε να τοποθετηθεί ο ένθετος χάρτης. Θα παρατηρήσετε ότι τώρα υπάρχουν 2 χαρτογραφικά αντικείμενα στην Διάταξη εκτύπωσης. Κάθε φορά που προβαίνετε σε αλλαγές βεβαιωθείτε ότι έχετε επιλεγμένο τον σωστό χάρτη.

../../_images/168.png
  1. Επιλέξτε το αντικείμενο Χάρτης 2 που μόλις προσθέσατε από τον πίνακα Στοιχεία. Επιλέξτε τον φάκελο ιδιοτήτων Ιδιότητες στοιχείου. Κυλίστε προς τα κάτω έως τον πίνακα Πλαίσιο και επιλέξτε το τετραγωνίδιο δίπλα απο αυτόν. Μπορείτε να αλλάξετε το χρώμα και το πάχος του περιγράμματος του πλαισίου ώστε αυτό να ξεχωρίζει εύκολα μέσα στο φόντο του χάρτη.

../../_images/179.png
  1. Μια έξυπνη λειτουργία της Διάταξης εκτύπωσης είναι ότι μπορεί αυτόματα να επισημάνει την περιοχή του χάρτη που αναπαρίσταται στο ένθετο. Από τον πίνακα Στοιχεία επιλέξτε το αντικείμενο Χάρτης 1. Στον φάκελο Ιδιότητες στοιχείου κυλείστε στην ενότητα Επισκοπήσεις. Πατήστε το κουμπί Προσθήκη νέας επισκόπησης.

../../_images/188.png
  1. Επιλέξτε Χάρτης 2 ως Πλαίσιο χάρτη. Αυτό λέει στην Διάταξη εκτύπωσης να επισημάνει το τρέχων αντικείμενο Χάρτης 1 με την έκταση του χάρτη που φαίνεται στο αντικείμενο Χάρτης 2.

../../_images/197.png
  1. Τώρα που έχουμε τον ένθετο χάρτη έτοιμο θα προσθέσουμε στον κύριο χάρτη ένα πλέγμα. Επιλέξτε το αντικείμενο Χάρτης 1 από τον πίνακα :guilabel:Στοιχεία. Στον φάκελο Ιδιότητες στοιχείου κυλήστε προς τα κάτω στην ενότητα Πλέγματα. Πατήστε το κουμπί Προσθήκη νέου πλέγματος και μετά το πλήκτρο Τροποποίηση πλέγματος....

../../_images/206.png
  1. Ως αρχική ρύθμιση οι γραμμές του πλέγματος χρησιμοποιούν τις ίδιες μονάδες και προβολές με τις προβολές του τρέχοντος επιλεγμένου χάρτη. Όμως συνηθίζεται και είναι χρήσιμο οι γραμμές του πλέγματος να εμφανίζονται σε μοίρες. Μπορούμε να επιλέξουμε ένα διαφορετικό CRS για το πλέγμα. Πατήστε το κουμπί Αλλαγή... δίπλα στο CRS.

../../_images/2112.png
  1. In the Coordinate Reference System Selector dialog, enter 4326 in the Filter box. From the results, select the WGS84 EPSG:4326 as the CRS. Click OK.
../../_images/2210.png
  1. Select the Interval values as 5 degrees in both X and Y direction. You can adjust the Offset to change where the grid lines appear.
../../_images/235.png
  1. Scroll down to the Grid frame section and check the Draw coordinates box. The default format is Degrees but it appears as a number. We can customize is to append a ° symbol. Choose Custom and click the Expression button next to it.
../../_images/245.png
  1. Enter the following expression to create a string that takes the grid number and appends ° symbol to it.
concat(to_string(@grid_number), '°    ')
../../_images/254.png
  1. Notice that the grids now have a custom label from the expression. Adjust the position settings for Left, Right, Top and Bottom as per your liking.
../../_images/264.png
  1. Now we will add a Rectangluar frame to hold other map elements like north arrow, scale and label. Go to Add Item ‣ Add Shape ‣ Add Rectangle.
../../_images/274.png
  1. You can change the Style of the rectangle to match the map background.
../../_images/284.png
  1. Now we will add a North Arrow to the map. QGIS comes with a nice collection of map-related images - including many types of North Arrows. Click Add Item ‣ Add Picture.
../../_images/293.png
  1. Holding your left mouse button, draw a rectangle. On the right-hand panel, click on the Item Properties tab and expand the Search directories section and select the image of your liking.
../../_images/303.png
  1. Now we will add a scale bar. Click on Add Item ‣ Add Scalebar.
../../_images/3110.png
  1. Click on the layout where you want the scalebar to appear. In the Item Properties tab, make sure you have chosen the correct map element Map 1 for which to display the scalebar. Choose the Style that fit your requirement. In the Segments panel, change the Fixed width to 200 units and adjust the segments to your liking.
../../_images/326.png
  1. It is time to label our map. Click on Add Item ‣ Add Label.
../../_images/331.png
  1. Click on the map and draw a box where the label should be. In the Item Properties tab, expand the Label section and enter a label for the map. Similarly add another labels for data and software credits.
../../_images/341.png
  1. Once you are satisfied with the map, you can export it as an Image, PDF or SVG. For this tutorial, let’s export it as an image. Click Layout ‣ Export as Image.
../../_images/351.png
  1. Save the image in the format of your liking. Below is the exported PNG image.
../../_images/output.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License