Δημιουργία ενός χάρτη

Συχνά, χρειάζεται να δημιουργηθεί ένας χάρτης , ο οποίος μπορεί να εκτυπωθεί η να

Επισκόπηση της εργασίας

Ο παρών οδηγός εκμάθησης παρουσιάζει την δημιουργία ενός χάρτη της Ιαπωνίας με βασικά στοιχεία χαρτογράφησης όπως η ένθεση, οι γραμμές πλέγματος, το σημείο προσανατολισμού, η κλίμακα και οι ετικέτες.

Άλλες ικανότητες που θα μάθετε

  • Χρησιμοποιώντας την CRS μετατροπή για να οπτικοποιήσετε τα δεδομένα σας σε διαφορετική προβολή.

Πάρτε τα δεδομένα

Θα χρησιμοποιήσουμε το σύνολο δεδομένων Natural Earth – ειδικά το Natural Earth Quick

Download the Natural Earth Quickstart Kit.

Πηγή δεδομένων

Διαδικασία

  1. Κάντε λήψη και εξαγάγετε τα δεδομένα Natural Earth Quick Start Kit. Ανοίξτε το QGIS. Κάντε

../_images/190.png
  1. Κάντε περιήγηση στο κατάλογο όταν έχετε εξαγάγει τα δεδομένα natural earth. Θα πρέπει

../_images/236.png
  1. Θα δείτε πολλά στρώματα στο πίνακα περιεχομένου και ένα στυλιζαρισμένο χάρτη του

../_images/324.png
  1. Σε αυτόν τον οδηγό εκμάθησης, θα φτιάξουμε ένα χάρτη της Ιαπωνίας. Κάντε κλικ :guilabel:`

../_images/418.png
  1. Μπορείτε να απενεργοποιήσετε τα στρώματα των δεδομένων που δεν χρειάζεστε για αυτόν τον χάρτη. Αποεπιλέξτετο κουτί δίπλα στα στρώματα 10m_geography_marine_polys και``10m_admin_0_map_units``. Πριν δημιουργήσουμε έναν χάρτη έτοιμο για εκτύπωση, θα πρέπει να επιλέξουμε μια κατάλληλη προβολή. Τα συγκεκριμένα δεδομένα βρίσκονται σε ένα Συστημα Γεωγραφικών Συντεταγμένων (ΣΓΣ) του οποίου οι μονάδες είναι σε βαθμούς. Αυτό δεν είναι κατάλληλο για έναν χάρτη στον οποίο θέλετε οι αποστάσεις να μετρώνται σε χιλιόμετρα ή μίλια. Θα πρέπεινα χρησιμοποιήσετε ένα Σύστημα Συντεταγμένων το οποίο να ελαχιστοποιεί τις στρεβλώσεις στην περίοχή μελέτης και οι μονάδες του να είναι σε μέτρα. Η Εγκάρσια Μερκατορική προβολή (UTM) είναι μια ικανοποιητική επιλογή ως σύστημα συντεταγμένων. Επιπρόσθετα, η Εγκαρσια Μερκατορική ειναι καταλληλή για παγκόσμιο επίπεδο και κατ’ επέκταση είναι μια καλή εξ’ ορισμού επιλογή στην οποία μπορείτε να βασιστείτε και να επιλέξετε μια ζώνη της η οποία να περιέχει την περιοχή μελέτης για να ελαχιστοποιηθούν οι στρεβλώσεις στην γενικότερη περιοχή. Στην περίπτωση αυτή, θα χρησιμοποιήσουμε την UTM ζώνη 54Ν. Κάντε κλικ στο κουμπί CRS Status στην κάτω-δεξιά γωνία του παραθύρου του QGIS

Note

Για την Ιαπωνία, Japan Plane Rectangular CS, είναι ένα προβλεπόμενο σύστημα αναφοράς

../_images/518.png
  1. Check the Enable on-the-fly CRS Transformation box. Type Tokyo utm zone54n in the Filter search box. Once you see the results, select Tokyo / UTM Zone 54N - EPSG:3095. Click Apply.
../_images/617.png
  1. Τώρα μπορείτε να συναρμολογήσετε τον χάρτη σας. Πηγαίνετε στο Project ‣ New Print Composer.

../_images/716.png
  1. Θα χρειαστεί να εισάγετε ένα τίτλο για την σύνθεση. Μπορείτε να το αφήσετε κενό και να πατήσετε Ok.

Note

Αφήνωντας το όνομα της σύνθεσης άδειο θα δημιουργηθεί ένα προεπιλεγμένο όνομα όπως “Σύνθεση 1”

../_images/816.png
  1. Στο παράθυρο εκτύπωσης της σύνθεσης, πατήστε στο Zoom full για να απεικονίσετε την πλήρη έκταση της διάταξης. Τώρα θα πρέπει να μεταφέρουμε την έκταση του χάρτη όπως την βλέπουμε στον καμβά της σύνθεσης στο QGIS. Πηγαίνετε στο Layout ‣ Add Map-Προσθήκη Χάρτη.

../_images/1015.png
  1. Μόλις το κουμπί : guilabel : ` Πρόσθεσε χάρτη ` είναι ενεργό, κρατήστε πατημένο το

../_images/1118.png
  1. Θα δείτε οτι στο παραλληλόγραμμο παράθυρο εμφανίζεται ο χάρτησ με τον χάρτη από τον κεντρικό καμβά του QGIS. Η απόδοση του χάρτη μπορεί να μην καλύπτει την πλήρη έκταση της περιοχής μελέτης. Επιλέξτε Layout ‣ Move item content για να μετακινήσετε τον χάρτη στο παράθυρο και να τον κεντράρετε στο κέντρο του παραθύρου.

../_images/1217.png
  1. Ας ρυθμίσουμε το επίπεδο μεγένθυσης για τον συγκεκριμένο χάρτη. Πατήστε στην καρτέλα Item Properties-ιδιότητες και εισάγετε την τιμή 7000000 for Scale-κλίμακα

../_images/1315.png
  1. Τώρα θα εισάγουμε τον χάρτη που απεικονίζει μια μεγενθυμένη εικόνα της περιοχής του Τόκιο. Πριν κάνουμε οποιαδήποτε αλλαγή στην στρώματα στο κεντρικό παράθυρο του QGIS, επιλέξτε τα κουτιά Lock layers for map item και:guilabel:Lock layer styles for map item. Αυτό θα εξασφαλίσει οτι αν απενεργοποιήσουμε μερικά από τα στρώματα ή αλλάξουμε τον συμβολισμό τους, αυτή η απεικόνιση δεν θα αλλάξει.

../_images/1413.png
  1. Πηγαίνετε στο κεντρικό παράθυρο του QGIS. Χρησιμοποιείστε το κουμπί Zoom In για να μεγενθύνετε την περιοχή γύρω από το Τόκιο

../_images/1513.png
  1. Υπάρχουν μερικές διπλές ετικέτες οι οποίες προέρχονται από το στρώμα “ne_10m_populated_places``. Μπορειτε να το απενεργοποιείσετε αυτό το στρώμα για την συγκεκριμένη απεικόνιση.

../_images/1612.png
  1. Τώρα είμαστε σε θέση να εισάγουμε το χάρτη. Πηγαίνετε στο παράθυρο Print Composer . Πηγαίνετε στο Layout ‣ Add Map- Προσθήκη χάρτη.

../_images/1711.png
  1. Σύρετε ένα παραλληλόγραμμο στην θέση που θέλετε να προσθέσετε τον χάρτη. Τώρα θα παρατηρήσετε οτι έχετε 2 αντικείμενα χάρτη στην σύνθεση της εκτύπωσης. Όταν κάνετε αλλαγές, φροντίστε να έχετε επιλεγμένο τον σωστό χάρτη. Επιλέξτε τον Map 1-Χάρτη1 τον οποίο μόλις εισάγατε από το παράθυρο Items. Επιλέξτε την καρτέλα Item properties. Μετακινηθείτε προς τα κάτω στο παράθυρο Frame και επιλέξτε το κουμπί που βρίσκεται δίπλα. Μπορείτε να αλλάξετε το χρώμα και το πάχος της κορνίζας ώστε να μπορείτε να το ξεχωρίζετε χρησιμοποιώντας το φόντο του.

../_images/1811.png
  1. Ενα ενδιαφέρον χαρακτηριστικό της σύνθεσης εκτύπωσης είναι οτι μπορεί να δώσει έμφαση στην περιοχή του κεντρικού χάρτη που εμφανίζεται στην κορνίζα αυτόματα. Επιλεξτε το αντικείμενο``Map 0` από το παράθυρο guilabel:Items. Στην καρτέλα Item properties tab, μετακινηθείτε πρός τα κάτω στο τμήμα Overviews. Πατήστε το κουμπί Add a new overview.

../_images/199.png
  1. Επιλέξτε το Map 1 ως το Map Frame”. Αυτή η πράξη μας, δείχνει στον σύνθεση της εκτύπωσης οτι πρέπει να δώσει έμφαση στο τρέχον αντικείμενο ``Map 0` με την έκταση του χάρτη να είναι αυτή που φαίνεται στο Map 1.

../_images/206.png
  1. Τώρα που έχουμε την ένθεση του χάρτη έτοιμη, θα προσθέσουμε ένα πλέγμα και ένα περίγραμμα τύπου ζέβρα στον κεντρικό χάρτη. Επιλέξτε το αντικείμενο Map 0 από το παράθυρο Items. Στην καρτέλα Item properties μεταφερθείτε προς τα κάτω στο τμήμα Grids. Πατήστε το κουμπί Add a new grid.

../_images/2112.png
  1. Εξ’ ορισμού, οι γραμμές του πλέγματος χρησιμοποιούν τις ίδιες μονάδες και προβολή η οποία έχει επιλεχθεί ως η τρέχουσα προβολή του χάρτη. Παρόλα αυτά, είναι πιο κοινό και χρήσιμο να προβάλεις τις γραμμές πλέγματος σε μονάδες. Μπορείτε να επιλέξετε ένα διαφορετικό σύστημα συντεταγμένων για το πλέγμα. Πατήστε στο κουμπί change... και έπειτα στο CRS.

../_images/2211.png
  1. Στο παράθυρο διαλόγου Coordinate Reference System Selector και εισάγετε 4326 στο κουτί Filter. Από τα αποτελέσματα, επιλέξτε το WGS84 EPSG:4326 ως το σύστημα συντεταγμένων. Και πατήστε οκ OK.

../_images/237.png
  1. Επιλέξτε τις τιμές Interval και βάλτε 5 βαθμούς σε κάθε διεύθυνση X και Y. Μπορείτε να προσαρμόσετε την αντιστάθμιση Offset για να αλλάξετε το που θα εμφανίζονται οι γραμμές του πλέγματος.

../_images/245.png
  1. Μετακινηθείτε προς τα κάτω στο τμήμα Grid frame και επιλέξτε το στυλ της κορνίζας που θέλετε. Επιπλέον, επιλέξτε το κουτί Draw coordinates.

../_images/254.png
  1. Προσαρμόστε την απόσταστη του χάρτη από την κορνίζα του Distance to map frame μέχρι οι συντεταγμένες να είναι ευανάγνωστες. Αλλάξτε την ακρίβεια Coordinate precision to 1 ώστε οι συντεταγμένες να εμφανίζουν μόνο το πρώτο δεκαδικό.

../_images/264.png
  1. Τώρα μπορείτε να προσθέσετε σημείο Βορρά στον χάρτη. Η Σύνθεση της Εκτύπωσης συμπεριλαμβάνει μια ωραία συλλογή από εικόνες σχετικές με τους χάρτες- που περιλαμβάνου πολλών ειδών σημεία Βορρά. Επιλέξτε το Layout ‣ Add Image- προσθήκη εικόνας.

../_images/274.png
  1. Κρατώντας το αριστερό πλήκτρο του ποντικιού σας, σχεδιάστε ένα ορθογώνιο στη πάνω

../_images/282.png
  1. Τώρα θα προσθέσουμε μια μπάρα κλίμακας. Κάντε κλικ στο :menuselection:`

../_images/293.png
  1. Κάντε κλικ στο σημείο που θέλετε να εμφανίζεται η ράβδος της κλίμακας. Στην καρτέλα Item Properties-Ιδιότητες, φροντίστε να έχετε επιλεγμένο το σωστό χάρτη για τον οποίο φτιάχνετε την κλίμακα. Επιλέξτε τον συμβολισμό που ταιριάζει με τις απαιτήσεις σας. Στο παράθυρο Segments μπορείτε να προσαρμόσετε τον αριθμό και το μέγεθος των τμημάτων.

../_images/303.png
  1. Είναι ώρα να βάλουμε ετικέτες στον χάρτη. Πατήστε στο Layout ‣ Add Label-Προσθήκη ετικέτας.

../_images/3111.png
  1. Κάντε κλικ στο χάρτη και σχεδιάστε ένα πλαίσιο όπου θα πρέπει να είναι η ετικέτα. Στη

<div align=center>
<h1>Map of Japan</h1>
</div>
../_images/325.png
  1. Ομοίως εισάγετε ακόμα μια ετικέτα για να προσθέσετε τα δεδομένα και τα στοιχεία των δημιουργών.

../_images/332.png
  1. Μόλις είστε ικανοποιημένοι με το χάρτη, μπορείτε να τον εξαγάγετε ως εικόνα, PDF ή SVG.

../_images/342.png
  1. Αποθηκεύστε την εικόνα στη μορφή της αρεσκείας σας. Παρακάτω είναι η εξαγόμενη PNG

../_images/352.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License