Створення мапи

Часто виникає потреба створити мапу, придатну для друку чи публікації. Для цієї задачі в QGIS є потужний інструмент під назвою Print Composer, що дозволяє пакувати ваші шари ГІС для створення мапи.

Огляд завдання

В цьому уроці ви дізнаєтесь, як створити мапу Японії зі стандартними елементами: вставною мапою, сіткою, вказівником півночі, шкалою та позначками.

Додаткові навички

  • Перетворення систем координат «на льоту» для перегляду даних в різних проекціях.

Отримання даних

Ми будемо використовувати набір даних Natural Earth, а саме — Natural Earth Quick Start Kit, що містить набір чудово оформлених глобальних шарів, які можна завантажувати безпосередньо в QGIS.

Download the Natural Earth Quickstart Kit.

Джерело даних [NATURALEARTH]

Виконання

  1. Завантажте та витягніть дані Natural Earth Quick Start Kit з архіву. Запустіть QGIS. Натисніть Project ‣ Open.

../_images/190.png
  1. Перейдіть в директорію з витягнутими даними Natural Earth. Ви маєте побачити файл з назвою Natural_Earth_quick_start_for_QGIS.qgs. Це файл проекту, що містить оформлені шари у форматі документів QGIS. Клацніть Open.

../_images/236.png
  1. Ви побачите перелік шарів у таблиці ліворуч, і оформлену мапу світу в робочому полі QGIS. Якщо ви бачите сповіщення про помилку у верхній частині поля, клацніть по хрестику, щоб прибрати його.

../_images/324.png
  1. На цьому уроці ми оформимо мапу Японії. Натисніть кнопку Zoom In, та обведіть прямокутник довкола Японії, щоб збільшити цю ділянку.

../_images/418.png
  1. Ви можете вимкнути шари даних, що не будуть використовуватись у цій мапі. Для цього зніміть прапорці біля шарів 10m_geography_marine_polys та 10m_admin_0_map_units. Перед створенням придатної для друку мапи, необхідно визначитись із проекцією. Наш набір даних подано у Geographic Coordinate System (GCS), де одиницями виміру є градуси. Але це не підходить для мап, в яких для виміру відстаней потрібно користуватись кілометрами або милями. Ми маємо взяти координатну систему проекцій, яка зменшить спотворення потрібної нам області, і буде мати одиниці виміру у метрах. Universal Transverse Mercator (UTM) є гарним вибором для наших цілей. Вона є глобальною, і тому підійде у більшості випадків. Залишається вибрати відповідну зону UTM, яка містить потрібну нам ділянку — це необхідно зробити для зменшення викривлень (дисторсії). У нашому випадку ми виберемо зону UTM 54N. Натисніть кнопку CRS Status у правому нижньому куті вікна QGIS.

Примітка

Для Японії розроблено координатну систему Japan Plane Rectangular CS (частина системи CRS — coordinate reference system), яка дає найменше спотворень. Вона розділена на 18 ділянок, і якщо ви працюєте з маленькою зоною в Японії — ця CRS підходить якнайкраще.

../_images/518.png
  1. Поставте прапорець Enable on-the-fly CRS Transformation. У пошуковому рядку Filter введіть Tokyo utm zone54n. У знайденому виберіть Tokyo / UTM Zone 54N - EPSG:3095. Клацніть Apply.

../_images/617.png
  1. Тепер ми можемо розпочати збирання нашої мапи. Перейдіть до Project ‣ New Print Composer (Ctrl+P).

../_images/716.png
  1. Вам запропонують ввести назву нашої збірки. Можете залишити поле пустим і натиснути Ok.

Примітка

Якщо ви залишили поле назви пустим, буде вжито назву за умовчанням на кшталт Composer 1.

../_images/816.png
  1. У вікні Print Composer клацніть по Zoom full для відображення всієї збірки. Тепер ми маємо перенести вид мапи з робочого поля QGIS до вікна Print Composer. Перейдіть до Layout ‣ Add Map.

../_images/1015.png
  1. Після натиснення кнопки Add Map, затисніть ліву кнопку миші і намалюйте прямокутник там, де ви хочете вставити мапу.

../_images/1118.png
  1. Ви побачите, що в прямокутнику відрисувалась мапа з робочого поля QGIS. Але вона не завжди відображає всю потрібну нам область. Виберіть Layout ‣ Move content (C) для переміщення мапи у вікні, або Layout ‣ Move item (V) для зміни меж вставки у вікні збірки.

../_images/1217.png
  1. Давайте настроїмо рівень масштабування для нашої мапи. У закладці Item Properties, введіть значення 7000000 до Scale.

../_images/1315.png
  1. Тепер ми додамо вставну мапу, в якій покажемо Токіо у збільшеному масштабі. Перш ніж вносити будь-які зміни у шари в робочому полі QGIS, поставте прапорці Lock layers for map item та Lock layer styles for map item. Це забезпечить незмінність вигляду, навіть якщо ми вимкнемо деякі шари, або змінимо їх стилі.

../_images/1413.png
  1. Перейдіть у головне вікно QGIS. Скористайтесь кнопкою Zoom In для наближення ділянки біля Токіо.

../_images/1513.png
  1. З’являться деякі дубльовані позначки з шару ne_10m_populated_places. Ви можете вимкнути цей шар для цього виду.

../_images/1612.png
  1. Тепер ми готові додавати вставну мапу. Перейдіть у вікно Print Composer. Виберіть Layout ‣ Add Map.

../_images/1711.png
  1. Протягніть прямокутник там, де ви хочете додати вставну мапу. Тепер у вас дві мапи у вікні збірки. При внесенні змін переконайтесь, що вибрали потрібну мапу. Виберіть об’єкт Map 1, який ми тільки що додали, у закладці Items. Перейдіть до закладки Item properties. Прокрутіть вниз до рядка Frame, і поставте прапорець біля нього. Ви можете змінювати колір та товщину обведення, для того щоб краще вирізнити вставну мапу на тлі основної.

../_images/1811.png
  1. Зручною функцією вікна збірки є автоматичне підсвічування площі основної мапи, яка представлена у вашій вставці. Виберіть Map 0 у закладці Items. В закладці Item properties прокрутіть вниз до секції Overviews. Натисніть кнопку Add a new overview.

../_images/199.png
  1. Виберіть Map 1 у Map Frame. У вікні збірки на мапі Map 0 має підсвітитись площа вставної мапи``Map 1``.

../_images/206.png
  1. Тепер, коли ми створили вставну мапу, додамо сітку та смугасту обводку до основної мапи. Виберіть об’єкт Map 0 на закладці Items. У закладці Item properties прокрутіть вниз до секції Grids. Натисніть кнопку Add a new grid.

../_images/2112.png
  1. За умовчанням, сітка використовує ті ж одиниці виміру, що й вибрана картографічна проекція. Та все ж, часто потрібно відобразити сітку у градусах. Ми можемо вибрати іншу CRS для сітки. Натисніть кнопку change... праворуч від CRS.

../_images/2211.png
  1. В діалоговому вікні Coordinate Reference System Selector введіть у поле пошуку 4326. В результатах виберіть WGS 84 EPSG:4326 як потрібну CRS. Натисніть OK.

../_images/237.png
  1. Введіть 5 градусів як значення проміжків Interval в обох напрямках: X та Y. Також можна використовувати Offset для зміщення ліній сітки.

../_images/245.png
  1. Прокрутіть вниз до розділу Grid frame, та виберіть вигляд рамки, який вам найбільше подобається. Також поставте прапорець біля Draw coordinates.

../_images/254.png
  1. Відрегулюйте відстань координат до рамки у полі Distance to map frame. Змініть значення поля Coordinate precision на 1 для відображення координат з точністю до одного знаку після коми.

../_images/264.png
  1. Тепер ми додамо на мапу вказівник півночі. Вікно збірки має чудову добірку зображень для мап, включно з великою кількістю вказівників. Натисніть Layout ‣ Add Image.

../_images/274.png
  1. Затисніть ліву кнопку миші, і намалюйте прямокутник у верхньому правому куті поля мапи. У правій панелі виберіть закладку Item Properties, розкрийте розділ Search directories і виберіть вказівник півночі, який вам подобається найбільше.

../_images/282.png
  1. Тепер ми додамо масштабну лінійку. Натисніть Layout ‣ Add Scalebar.

../_images/293.png
  1. Клацніть там, де ви хочете додати мірило. У закладці Item Properties переконайтесь, що ви вибрали правильний елемент мапи, для якої потрібно показати масштабну лінійку. У розділі Segments ви можете настроїти кількість сегментів та їх розмір.

../_images/303.png
  1. Саме час підписати нашу мапу. Натисніть Layout ‣ Add Label.

../_images/3111.png
  1. Клацніть на мапі і намалюйте прямокутник, в якому має розміщуватись підпис. У закладці Item Properties розкрийте розділ Label і введіть текст, як показано нижче. Також можна ввести текст у HTML. Поставте прапорець навпроти Render as Html для того, щоб програма могла розуміти теґи HTML.

<div align=center>
<h1>Map of Japan</h1>
</div>
../_images/325.png
  1. Так само додайте ще один підпис із вихідними даними та назвою програми.

../_images/332.png
  1. Якщо ви задоволені мапою, її можна експортувати як растрове зображення, PDF або SVG. В цьому уроці збережемо її як растрове зображення. Натисніть Composer ‣ Export as Image.

../_images/342.png
  1. Збережіть зображення у потрібному вам форматі. Нижче показано результат збереження у форматі PNG.

../_images/352.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License