Bir harita oluşturma

Çıktısı alınabilen veya yayınlanabilen bir haritaya sık sık ihtiyaç duyulmaktadır. QGIS CBS katmanlarını alıp harmanlayarak haritalar oluşturmanıza olanak sağlayan ‘ Çıktı Düzenleyici ‘ adı verilen güçlü bir araca sahiptir.

Göreve Genel Bakış

Bu eğitimde Japonya’nın bir haritasının harita eki , ızgaralar , Kuzey Yönü ibresi , ölçek çubuğu ve etiketler gibi standart harita elemanlarıyla nasıl oluşturulacağı öğretilmektedir.

Öğreneceğiniz diğer beceriler

  • Verilerinizi farklı bir tasarımda görselleştirmek için ‘ Anında Koordinat Referans Sistemi Dönüşümü’ nü ‘’KRS’’ kullanma ‘on-the-fly’ CRS transformation ‘

Veriyi elde edin

Doğal Dünya veri setini yani özellikle QGIS’e direkt olarak yüklenebilen mükemmel tasarlanmış küresel katmanlar ile gelen Natural Earth Quick Start Kit’i kullanacağız.

Natural Earth Quick Start Kit’i indirin : <http://naciscdn.org/naturalearth/packages/Natural_Earth_quick_start.zip>`_.

Veri Kaynağı : [NATURALEARTH]

İşlem Basamakları

  1. Natural Earth Quick Start Kit verisini indirip arşivden çıkartınız. QGIS’ i açınız. Sırasıyla Proje ‣ Aç. ‘a tıklayınız

../_images/190.png
  1. Arşivi çıkardığınız klasöre gidiniz. Klasörde Natural_Earth_quick_start_for_QGIS.qgs. adlı bir dosya göreceksiniz. Bu QGIS dökümanı formatında düzenlenmiş katmanlar içeren proje dosyasıdır. . a tıklayınız.

../_images/236.png
  1. QGIS kanvasında, içerik tablosunda çok sayıda katman ve dizayn edilmiş bir dünya haritası görürsünüz. Tuvalin üstünde görüntülenen hataları görürseniz, kapatmak için çarpıya tıklayınız.

../_images/324.png
  1. Bu derste, Japonya’nın bir haritasını yapacağız. :guilabel: ` Zoom In` düğmesine tıklayınız ve bölgeyi yakınlaştırmak için Japonya’nın çevresinde bir dikdörtgen çiziniz.

../_images/418.png
  1. Bu harita için ihtiyaç duymadığımız bazı katmanları kapatabilirsiniz. 10m_geography_marine_polys ve 10m_admin_0_map_units in yanındaki kutucukların işaretlerini kaldırınız.Baskıya uygun bir harita yapmadan önce uygun bir projeksiyon yani ‘’ yansıtma , izdüşüm ‘’ seçmemiz gerekir. Bu veri seti birimlerin derece olduğu Coğrafik Koordinat Sistemi’nden ( GCS: Geographic Coordinate System ) alınmıştır. Bu mesafelerin kilometre veya mil olarak istenen bir harita için uygun değildir. İlgilendiğimiz bölge için metre birimlerini içeren ve hataları minimize eden a Projected Coordinate System’i yani Tasarlanmış Koordinat Sistemi kullanmamız gerekir. Universal Transverse Mercator (UTM) tasarlanmış koordinat sistemi için iyi bir seçimdir. Aynı zamanda globaldir, bu yüzden bölgenizdeki bozulmaları en aza indirgemek için ilgi alanınızı içeren bir UTM bölgesine güvenebileceğiniz ve seçebileceğiniz iyi bir varsayılandır. Biz UTM Zone 54N ‘ i kullanacağız. QGIS penceresinin sağ üst köşesindeki CRS Status  butonunu tıklayınız.

Not

Japonya için, Japonya Düzlemi Dikdörtgen Koordinat Sistemi, minimum bozukluklar için tasarlanmış, öngörülen bir koordinat referans sistemidir (CRS). Bu sistem 18 bölgeye ayrılmıştır ve Japonya’da daha küçük bir bölge için çalışıyorsanız, bu CRS’yi kullanmak daha iyi olacaktır.

../_images/518.png
  1. Check the Enable on-the-fly CRS Transformation box. Type Tokyo utm zone54n in the Filter search box. Once you see the results, select Tokyo / UTM Zone 54N - EPSG:3095. Click Apply.
../_images/617.png
  1. Şimdi haritamızı birleştirebiliriz. Project ‣ New Print Composer menüsüne gidiniz.

../_images/716.png
  1. Composer için bir başlık girmeniz istenebilir. İsnerseniz boş bırakabilirsiniz. Ok e tıklayınız.

Not

Composer adı boş bırakılırsa ``Composer 1` bir varsayılan isim atanır.

../_images/816.png
  1. Print Composer penceresinde , planın tam kapsamını görüntülemek için Zoom full e tıklayınız. Şimdi, QGIS Canvas’da gördüğümüz harita görünümünü besteciye getirmemiz gerekecektir. Layout ‣ Add Map menüsüne gidiniz.

../_images/1015.png
  1. Once the Add Map button is active, hold the left mouse button and drag a rectangle where you want to insert the map.
../_images/1118.png
  1. Dikdörtgen pencerenin ana QGIS kanvasından harita ile işleneceğini göreceksiniz. İşlenmiş harita, ilgilendiğimiz alanın tüm kapsamını içermeyebilir. Pencerede haritayı kaydırmak ve composer içinde ortalamak için Layout ‣ Move item content i seçiniz.

../_images/1217.png
  1. Verilen harita için yakınlaştırma seviyesini ayarlayalım. Item Properties sekmesine tıklayınız ve Scale değeri olarak 7000000  değerini giriniz.

../_images/1315.png
  1. Şimdi Tokyo bölgesi için yakınlaştırılmış bir haritayı gösteren bir harita ekleyeceğiz. Ana QGIS penceresindeki katmanlarda herhangi bir değişiklik yapmadan önce Lock layers for map item ve Lock layer styles for map item kutularını işaretleyin. Bu, bazı katmanları kapatırsak veya stillerini değiştirmemiz durumunda, bu görünümün değişmemesini sağlar

../_images/1413.png
  1. Ana QGIS penceresine geçiş yapınız. Tokyo çevresindeki alanı yakınlaştırmak için Zoom In butonunu kullanınız.

../_images/1513.png
  1. ne_10m_populated_places katmanından gelen bazı çift etiketler var. Bu görünüm için bu katmanı kapatabilirsiniz.

../_images/1612.png
  1. Artık haritayı eklemek için hazırız. Print Composer penceresine geçiniz. Layout ‣ Add Map menüsüne gidiniz.

../_images/1711.png
  1. Harita ek bilgisini eklemek istediğiniz yerde bir dikdörtgeni sürükleyiniz. Artık Print Composer’da 2 harita nesnesine sahip olduğunuzu göreceksiniz. Değişiklikler yaparken, doğru haritanın seçildiğinden emin olunuz. Items panelinden eklemiş olduğumuz ``Map 1``  nesnesini seçiniz. Item properties sekmesini seçiniz. aşağı kaydırarak Frame paneline geliniz ve yanındaki kutucuğu işaretleyiniz. Çerçeve kenarının rengini ve kalınlığını değiştirebilirsiniz, böylece harita arka planına karşı kolayca ayırt edebilirsiniz.

../_images/1811.png
  1. Print Composer’ ın önemli bir özelliği ise ilave ettiğimiz alanın haritasını vurgulayarak ana harita üzerinde gösterebilmesidir. Items panelinden Map 0 nesnesini seçiniz. Item properties sekmesinde aşağı doğru kaydırarak Overviews bölümüne gidiniz. Add a new overview  butonuna tıklayınız.

../_images/199.png
  1. Map Frame olarak Map 1 i seçiniz. Burada Print Composer’, `` Harita 1`` nesnesi içinde geçerli haritamız `` Harita 0`` ı haritanın kapsamı ile vurgulamalıdır.

../_images/206.png
  1. İlave haritamız da hazır olduğuna göre , ana haritamız bir zebra çerçevesi ekleyeceğiz. Items panelinden ``Map 0`` nesnesini seçiniz. Item properties sekmesinde aşağı doğru kaydırarak Grids bölümüne gidiniz. Add a new grid butonuna tıklayınız.

../_images/2112.png
  1. Varsayılan olarak, grid çizgileri geçerli olarak seçilen harita projeksiyonları ile aynı birimleri ve projeksiyonları kullanır. Bununla birlikte, grid çizgilerini derece cinsinden görüntülemek daha yaygın ve yararlıdır. Grid için farklı bir CRS seçebiliriz. CRS in yanındaki change... butonuna tıklayınız.

../_images/2211.png
  1. Coordinate Reference System Selector penceresinde Filter kutusuna 4326 değerini giriniz. Sonuçlar içinde CRS olarak WGS84 EPSG:4326 yı seçiniz. OK e tıklayınız.

../_images/237.png
  1. X ve Y yönleri için Interval değerlerini 5 derece olarak seçiniz. Offset sekmesi ile grid çizgilerinin nerede görüneceğini ayarlayabilirsiniz.

../_images/245.png
  1. Zevkinize uygun bir çerçeve seçmek için aşağı doğru kaydırarak Grid frame bölümüne gidiniz. Ayrıca Draw coordinates kutucuğunu işaretleyiniz.

../_images/254.png
  1. Distance to map frame değerini koordinatlar okunur hale gelene kadar ayarlayınız. Koordinatlarda virgülden sonra sadece ilk hanesinin görünmesi için Coordinate precision değerini 1 olarak değiştiriniz.

../_images/264.png
  1. Şimdi haritaya bir Kuzey Oku ekleyeceğiz. Print Composer, birçok North Arrows türü de dahil olmak üzere, haritayla ilgili güzel resimlerden oluşan bir koleksiyon ile birlikte gelir. Layout ‣ Add Image e tıklayınız.

../_images/274.png
  1. Sol fare tuşunu basılı tutarken , harita tuvalinin sağ üst köşesinde bir dikdörtgen çiziniz. Sağ taraftaki panelde , Item Properties sekmesini tıklayınız ve Search directories  bölümünü açınız ve ardından isteğinize göre bir Kuzey Oku simgesi seçiniz.

../_images/282.png
  1. Şimdi bir ölçek çubuğu ekleyeceğiz. Layout ‣ Add Scalebar a tıklayınız.

../_images/293.png
  1. Planınızda ölçek çubuğunuzun görünmesini istediğiniz yere tıklayınız. Item Properties sekmesinde ölçek çubuğunun görüntüleneceği doğru harita elemanını seçtiğinizden emin olun.

../_images/303.png
  1. Haritamızı isimlerdimenin zamanı geldi. Layout ‣ Add Label a tıklayınız.

../_images/3111.png
  1. Haritaya tıklayınız ve etiketin olması gerektiği yere bir kutu çiziniz. Item Properties sekmesinde Label bölümünü açınız ve aşağıda gösterilen metni giriniz. Merni HTML olarak da girebiliriz. Metni HTML etiketine çevirmek için Render as Html kutucuğunu işaretleyiniz

<div align=center>
<h1>Map of Japan</h1>
</div>
../_images/325.png
  1. Data ve yazılım bilgisi eklemek için benzer şekilde bir başka etiket ekleyiniz.

../_images/332.png
  1. Haritanızdan memnun kaldığınızda bunu görüntü , PDF veya SVG olarak dışa aktarabilirsiniz. Bu ders için haritayı resim olarak dışa aktaralım. Composer ‣ Export as Image e tıklayınız.

../_images/342.png
  1. Resmi istediğiniz formatta kaydediniz. Aşağıda verilen resim PNG formatında kaydedilmiştir.

../_images/352.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License