Mosaik Raster dan Klipping

Tutorial ini mengekslplor sejumlah operasi raster dasar di QGIS seperti memperlihatkan, mosaicing atau penyatuan dan pembagian.

Tinjauan Tugas

Kita akan mengunduh sejumlah data raster dalam domain terbuka untuk Brazil dan melihatnya di QGIS. Berikutnya, kita akan menyatukan beberapa raster menjadi sebuah mosaik tunggal dan mengklipnya menggunakan batas negar untuk mendapat sebuah dataset untuk sebuah negara.

Skill lain yang akan anda pelajari

  • Mencari dan mengunduh pre-aktual citra satelit dari domain publik.

  • Memilih sebuah fitur tunggal dari sebuah layer vektor dan menyimpannya sebagai sebuah shapefile yang baru.

Mendapatkan data

Kita memerlukan Batas negara Brazil untuk mengklip raster kita. Anda bisa mendapat shapefile Admin 0 - Countries dari Natural Earth.

NASA/GSFC, Rapid Response site mempunyai koleksi bagus untuk pre-aktual citra satelit. Produk regional yang baik seperti USDA Foreign Agricultural Service (FAS) subsets. . Kita akan menggunakan resolusi FAS 2km untuk Brazil pada tutorial ini.

Berkiut bagaimana mencari dan mengunduh data yang relevan.

  1. Buka South America region subsets . Cari subset Brazil ditunjukkan pada bagian FAS Subsets , Klik salah satu.

../_images/1109.png
  1. Dalam Halaman yang detail, klik link 2km pada produk pilihan anda. Disini kita akan mengunduh produk NDVI product . Learn more about NDVI.

../_images/268.png
  1. Klik link Download GeoTIFF file untuk mengundul gambar raster

../_images/337.png

Ulangi proses untuk semua 7 FAS , Forest Agriculuture Service untuk Brazil.

Untuk kenyamanan, anda dapat dengan langsung mengunduh data sampel yang digunakan dalam tutorial ini dari link di bawah.

ne_10m_admin_0_countries.zip

FAS_Brazil1.2013363.aqua.ndvi.2km.tif

FAS_Brazil2.2013363.terra.ndvi.2km.tif

FAS_Brazil3.2013363.aqua.ndvi.2km.tif

FAS_Brazil4.2013363.aqua.ndvi.2km.tif

FAS_Brazil5.2013363.aqua.ndvi.2km.tif

FAS_Brazil6.2013363.terra.ndvi.2km.tif

FAS_Brazil7.2013363.aqua.ndvi.2km.tif

Sumber Data: [LANCE] [NATURALEARTH]

Prosedur

  1. Buka QGIS dan akses Layer ‣ Add Raster Layer...

../_images/427.png
  1. Jelajahi sampai direktori dengan isi gambar individu. Tahan tombol Ctrl dan klik file-file gambar tadi untuk membuat multi seleksi. Klik Open.

../_images/528.png
  1. Anda akan melihat gambar-gambar tadi terbuka di daftar isi pada panel sebelah kiri, Sekarang mari kita membuat citra Mosaic tunggal dari semua gambar ini. Klik Raster ‣ Miscellaneous ‣ Merge.

Catatan

Menu Raster di QGIS termasuk dalam plugin inti bernama GdalTools . Jika anda tidak melihat menu Raster, aktifkan plugin GdalTools dari Plugins ‣ Manage and install plugins ‣ Installed . Lihat docs/using_plugins untuk detail yang lebih jelas.

../_images/626.png
  1. Pada dialog Merge, klik Select... disebelah Input files dan jelajahi direktori yang berisi individu-individu file geotiff. Tahan Tombol Ctrl dan pilih semua subset. Sekarang klik Select... disebelah Output file dan beri nama output sebagai Brazil_mosaic.tif . Di sebelah bawah, centrang kotak to Load into canvas when finished . Klik OK.

../_images/725.png
  1. Anda akan mendapat pesan pop-up yang mengatakan Processing complete , ketika mosaik sudah tercipta dan terbuka di Kanvas QGIS. Anda dapat melihat bahwa individu-individu gambar dan sekarang sudah terkombinasi dan termosaik menjadi satu layer tunggal. Anda dapat menonaktifkan individu-individu layer dengan menghapus centrangan kotak disebelahnya.

../_images/824.png
  1. Operasi raster yang lain yang bisa anda lakukan adalah untuk mensubset atau crop sebuah gambar. Kita akan menggunakan sebuah poligon dari sebuah layer vector untuk mengcrop raster pada bentuk yang tepat. Mari buka shapefile poligon negara yang kita unduh dari Natural Earth. Akses Layer ‣ Add Vector Layer.

../_images/922.png
  1. Pilih file ne_10m_admin_0_countries.zip dan klik Open . Saat proses anda akan dibawa untuk memilih layer yang berada di file zip, pilih ne_10m_admin_0_countries.shp.

../_images/1023.png
  1. Ketika layer vektor sudah terbuka, kita ingin memilih dan mengekstrak poligon untuk Brazil. Pilih tool Select Single Feature dari toolbar.

../_images/1126.png
  1. Klik di mana saja pada poligon Brazil dan ini akan terpilih.

../_images/1224.png
  1. Klik kanan layer ne_10m_admin_0_countries dan pilih Save Selection As....

../_images/1321.png
  1. Beri nama ouput anda dengan brazil_boundary.shp dan pastikan box Add saved file to map aktif. Pilih OK.

../_images/1420.png
  1. Anda akan melihat poligon batas-batas Brazil sekarang terbuka di QGIS

../_images/1519.png
  1. Sekarang akses Raster ‣ Extraction ‣ Clipper.

../_images/1618.png
  1. Pilih input file (raster) dengan Brazil_mosaic . Beri nama Output file dengan Brazil_mosaic_clipped . Di Bagian Brazil_mosaic_clipped, pilih Mask layer . Pilih brazil_boundary yang baru saja dibuat sebagai layer mask atau masker. Centrang box Load into canvas when finished . Klik OK.

../_images/1717.png
  1. Layer yang baru saja dicrop akan terbuka di QGIS. Anda akan melihat bahwa pixel-pixel hitam mengelilingi mosaik yang sebenarnya. Mari kita hapus itu . Klik kanan pada layer Brazil_mosaic_clipped dan pilih Properties.

../_images/1817.png
  1. Akses tab Transparency , dan tambahkan 0 pada Additional no data value.

../_images/1915.png
  1. Sekarang anda sudah memiliki mosaik yang baik yang tercrop pada batas negara yang anda gunakan pada proyek ini sebagai layer latar belakang atau untuk objek analisis lebih jauh.

../_images/2012.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License