Poin di Analisis Poligon

Kekuatan GIS terletak dalam menganalisa sumber data berlipat atau multiple secara bersamaan. Sering kali jawaban yang anda cari terletak pada banyak layer yang berbeda dan anda perlu untuk melakukan beberapa analisa untuk mengekstrak dan mengkompile informasi ini. Satu dari beberapa analisis adalah Points-in-Polygon . Ketika anda mempunyai sebuah layer poligon dan sebuah layer poin- dan ingin tahu berapa banyak atau poin yang mana yang berhubungan pada tiap poligon, anda dapat menggunakan metode analisis ini.

Tinjauan Tugas

Diberikan lokasi dari semua gempa bumi yang signifikan, kita akan mencoba untuk mencari tahu negara mana yang mempunya kasus gempa bumi terbanyak.

Mendapatkan data

Kita akan menggunankan data dari NOAA’s National Geophysical Data Center’s Significant Earthquake Database <http://www.ngdc.noaa.gov/nndc/struts/form?t=101650&s=1&d=1>`_ sebagai layer kita untuk merepresentasikan semua gempa bumi yang besar. Unduh tab-delimited earthquake data.

Natural Earth punya Admin 0 - Countries dataset. Unduh the countries

For convenience, you may directly download a copy of the dataset from the link below:

signif.txt

ne_10m_admin_0_countries.zip

Sumber Data: [NGDC] [NATURALEARTH]

Prosedur

  1. Buka Layer ‣ Add Delimited Text Layer dan jelajah file yang sudah terunduh signif.txt .

../_images/1106.png
  1. karena ini adalah sebuah tab-delimited file, pilih Tab sebagai File format . X field dan Y field akan dipopulasikan secara otomatis. Klik OK.

Catatan

Anda mungkin melihat beberapa pesan error saat QGIS mencoba untuk mengimpor file. Ini adalah error yang valid dan beberapa baris dari file tidak akan terimpor. Anda bisa mengacuhkan error sebagai tujuan tutorial ini.

../_images/258.png
  1. Dataset gempabumi memiliki koordinat Latitude/Longitude, pilih WGS 84 EPSG:436 sebagi CRS pada dialog Coordinate Reference System Selector .

../_images/334.png
  1. The earthquake point layer would now be loaded and displayed in QGIS. Let’s also open the Countries layer. Go to Layer ‣ Add Vector Layer. Browse to the downloaded ne_10m_admin_0_countries.zip file and click Open. Select the ne_10m_admin_0_countries.shp as the layer in the Select layers to add... dialog.
../_images/424.png
  1. Klik Vector ‣ Analysis Tools ‣ Point in Polygon

../_images/525.png
  1. Pada jendela pop-up, piloih layer poligon dan layer poin berurutan. Beri nama layer hasil sebagai ``earthquake_per_coutry.shp` dan klik OK.

Catatan

Mohon untuk bersabar setelah mengklik OK, QGIS mungkin memerlukan waktu sampai 10 menit untuk mengkalkulasi hasilnya.

  1. Saat anda ditanyakan apakah anda ingin menambah layer ke TOC, klik Yes.

../_images/722.png
  1. Anda akan melihat sebuah layer baru ditambahkan ke daftar isi. Bukan tabel attribut dengan mengklik kanan pada layer dan memilih Open Attribute Table.

../_images/821.png
  1. Di Tabel attribut, anda akan melihat kolom baru bernama PNTCNT . Ini adalah jumlah poin dari layer gempabumi yang terletak pada setiap poligon.

../_images/919.png
  1. Untuk mendapatkan jawaban kita, kita dapat secara sederhana dengan mengurutkan tabel dari kolom PNTCNT dan negara dengan jumlah terbanyak adalah jawaban kita. Klik 2x pada kolom PNTCNT untuk mengurutkan dari paling akhir. Klik pada baris pertama untuk memilihnya dan tutup tabel attribut.

../_images/1020.png
  1. Kembali pada jendela utama QGIS, anda akan melihat satu fitur yang ditandai dengan warna kuning. Ini adalah fitur yang berhubungan dengan baris terpilih di table attribut yang mempunyai jumlah poin terbanyak. Pilih tool Identify dan klik pada poligon tersebut. Anda akan melihat negara dengan jumlah gempabumi yang paling signifikan adalah China.

../_images/1123.png

Kami mendapat dari analisis sederhana dari 2 dataset bahwa China kala itu mempunyai jumlah kasus gempabumi terbanyak. Anda bisa memperhalus analisis ini lebih jauh dengan mempertimbangkan populasi dan juga ukuran negara dan menentukkan negara mana yang paling banyak terkena dampak negatif gempabumi.

comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License