Melakukan Queries Spasial

Queries spasial adalah inti dari banyak analisis GIS. Pada QGIS, fungsi ini tersedia pada plugin ^**Spatial Query** .

Tinjauan Tugas

Kita akan bekerja dengan 2 tasets - Sebuah layer garis merepresentasikan sungai dan layer poin merepresentasikan kota. Tugas kali ini adalah menjalankan query spasial untuk menemukan semua kota yang berjarak 10 km dari sungai.

Skill lain yang akan anda pelajari

  • Buka file zip secara langsung di QGIS.

  • Memilih proyeksi yang cocok dan mereproyeksi data vektor.

  • Membuat buffer.

  • Memilih fitur menggunakan ekspresi seperti SQL.

  • Mengkonversi sebuah shapefile ke sebuah file kml.

  • Validasi hasil menggunakan Google Earth.

Mendapatkan data

Kita akan menggunakan dataset ne_10m_rivers_lake_centerlines dan 10m_populated_places_simple dari Natural Earth

Unduh Rivers and Lake Centerlines

Unduh Populated Places.

Sumber Data: [NATURALEARTH]

Prosedur

  1. Ketika anda sudah mengunduh data, buka QGIS, akses Layer ‣ Add Vector Layer.

../_images/1103.png
  1. Klik Browse dan navigasi ke folder di mana anda unduhan data zip anda berada.

../_images/248.png
  1. Tahan tombol Shift dan klik pada kedua file zip untuk memilih keduanya. Klik Open.

../_images/329.png
  1. Anda akan ditanyakan untuk memilih layer dari arsip zip. Pilih ne_10m_rivers_lake_centerlines.shp dan klik OK

../_images/421.png
  1. Karena anda sudah memilih multi file, ulangi proses untuk file berikutnya. Pilih 10m_populated_places_simple.shp dan klik OK.

../_images/522.png
  1. Anda akan melihat kedua shapefile terbuka di QGIS.

../_images/621.png
  1. Kita akan membuat buffer disekeliling layer poin dan garis. Tool geoprocessing Buffer di QGIS menggunakan layer units untuk menghitung jarak buffer. Layer yang kita punya menggunakan Geographic Coordinate Reference System (CRS) dalam unit degrees atau derajat . Ini tidak sesuai karena analisis kita menggunakan metres atau kilometres . Untuk mencapai tujuan ini, kita harus memproyeksi ulang atau re-proyeksi layer kita ke sebuah Projected Coordinate Reference System (CRS) . Klik kanan pada 10m_populated_places_simple layer dan pilih Save As.

../_images/720.png
  1. Pada dialog Save vector layer as... , klik Browse disebelah Save as dan pilih lokasi file output. Beri nama file output dengan``populated_places_reprojected.shp`` . Berikutnya klik tombol Browse disebelah CRS.

../_images/819.png
  1. Sekarang kita harus memilih CRS yang sesuai dengan tujuan kita. Untuk membuat buffer, sebuah Proyeksi Azimuthal Equidistance menjadi paling cocok karena jarak radial sekitar pusat proyeksinya akurat. Dalam kasus kita, karena dataset adalah global, kita akan memilih sebuah proyeksi dunia. Pada dialog Coordinate Reference System Selector , mulai cari dengan world az.. dan anda akan melihat hasilnya muncul. Pilih World_Azimuthal_Equidistant dan klik OK.

Catatan

Proyeksi World_Azimuthal_Equidistant merentang 90 derajat dari titik asal. Dalam hal ini titik asal berada di 0 derajat pada garis bujur, hanya data yang berisi informasi longitude atau garis bujur antara +/- derajat yang akan dikonversi.

../_images/917.png
  1. Kembali ke dialog Save vector layer as ... , beri tanda cek pada Add saved file to map dan klik OK.

../_images/1018.png
  1. Ulangi proses re-proyeksi untuk layer ne_10m_rivers_lake_centerlines dan simpan layer baru sebagai rivers_lake_reprojected.shp.

../_images/1121.png
  1. Sekarang anda akan memiliki 4 layer di Layers Panel . Hapus tanda cek pada kotak disebelah layer original untuk menampilkan layer yang sudah ter-reproyeksi saja. Layer yang sudah ter-reproyerksi masih dimunculkan dengan Geographic CRS karena settingannya. Mari non aktifkan itu. Klik tombol Project Properties. Pengaturan ini dapat juga diakses dari Project ‣ Project Properties.

../_images/1220.png
  1. Pada tab CRS dari dialog Project Properties , hapus tanda cek pada Enable on-the-fly CRS transformation . Klik OK.

../_images/1317.png
  1. Kembali ke jendela utama QGIS, klik kanan pada salahsatu layer yang sudah ter-reporoyeksi dan pilih Zoom to Layer Extent.

../_images/1416.png
  1. Sekarang anda akan melihat data dalam CRS layernya. Sekarang kita akan membuat buffer untuk kedua dataset. Klik Vector ‣ Geoprocessing Tools ‣ Buffer.

../_images/1515.png
  1. Pada tool Buffer , pilih layer populated_places_reprojected sebagai input. Masukkan buffer distance atau jarak buffer dengan 10000 . Perhatikan, karena kita menginginkan buffer dengan jarak 10 km dan unit CRS dalam meter, sehingga kita perlu memasukkan angka 10000 bukan 10. Masukkan nama file output dengan populated_places_buffer.shp . Klik OK.

../_images/1614.png
  1. Ketika proses buffer sudah selesai, klik Yes untuk menambahkan layer yang baru terbuat tadi ke dalam Table of Content atau TOC.

../_images/1713.png
  1. Ulangi proses buffer yang sama untuk layer rivers_lake_reprojected dan buat file output dengan nama``rivers_lake_buffer.shp``.

../_images/1813.png
  1. rivers_lake_buffer berisi fitur-fitur baik sungai ataupun danau. Analisis kita dijalankan untuk menggunakan fitur sungai saja, jadi kita akan menjalankan query untuk memilih fiur sungai saja. Klik kanan pada layer rivers_lake_buffer dan pilih Open Attribute Table.

../_images/1911.png
  1. Anda akan melihat bahwa attribut featurecla berisi informasi yang dapat kita gunakan untuk memilih fitur sungai. Klik tombol Select features using an expression .

../_images/208.png
  1. Masukkan ekspresi “featurecla” = “River” dan klik Select dan kemudian klik Close untuk kembali pada jendela utama QGIS.

../_images/2114.png
  1. Sekarang kita siap untuk melakukan query spasial. Anda perlu mengaktifkan Spatial Query plugin untuk menggunakan fungsi ini. lihat docs/using_plugins untuk detail lebih lanjut . Ketika plugin sudah aktif, akses Vector ‣ Spatial Query ‣ Spatial Query.

../_images/2213.png
  1. Untuk query kita, kita akan memilih fitur-fitur dari tempat yang masuk daerah buffer yang bersinggungan dengan garis sungai yang masuk daerah buffer. Pastikan beri tanda cek pada selected geometries . Ini untuk memastikan query hanya menggunakan fitur sungai yang sebelumnya sudah kita pilih atau memiliki tanda bahwa fitur ini terpilih. Klik Apply.

../_images/2310.png
  1. Ketika query sudah selesai, anda akan melihat bagian baru yang bernama Selected features . Klik tombol Create layer with selected . Sebuah layer baru akan ditambahkan ke Layers Panel . Klik Close.

../_images/249.png
  1. Zoom-in ke area mana saja dan bandingkan hasilnya. Anda akan melihat bahwa layer yang baru hanya berisi fitur yang bersinggungan dengan buffer sungai.

../_images/256.png
  1. Kita harus selalu memverifikasi hasil kita untuk memastikan analisa tidak cacat. Satu cara untuk memverifikasi hasilnya adalah dengan mengekspor layer ini menjadi file KML dan membukanya di Google Earth. Anda dapat memeriksa apakah area yang anda temukan bernar-benar berada pada radius 10 km dari sebuah sungai. Klik kanan layer dan klik Save As....

../_images/266.png
  1. Pada Save vector layer as... , pilih WGS84 sebagai CRS . Kita melakukan ini karena format KML harus mempunyai koordinat dengan CRS ini. Beri nama KML anda dengan cities_near_river.kml.

../_images/276.png
  1. Buka Google Earth dan verifikasi bahwa kota-kota terepresentasi oleh buffer-buffer yang dekat dengan sungai.

../_images/284.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License