Georeferensi Citra Udara

Pada tutorial docs/dasar_georeferensi kita meliput proses dasar untuk georeferensi di QGIS. Metode itu melibatkan membaca koordinat dari peta scan dan menginput secara manual. Walaupun sering kali anda mungkin tidak mempunyai koordinat yang tercetak pada peta anda, atau anda mencoba untuk melakukan georeferensi pada gambar. Dalam kasus perti itu, anda bisa menggunakan sumber data georeferensi lain sebagai input. Pada tutorial ini, anda akan belajar bagaimana menggunakan sumber terbuka yang sudah ada dalam proses georeferensi anda.

Tinjauan Tugas

Kita akan melakukan georeferensi pada citra resolusi tinggi menggunakan koordinat referensi dari OSM.

Skill lain yang akan anda pelajari

  • Mengunduh citra domain publik dengan resolusi super tinggi

  • Membuka plugin OpenLayer di QGIS

  • Mengkonversi koordinat antaranproyeksi yang berbeda menggunakan tool commandline xx2

  • Menggunakan sebuah layer tergeoreferensi untuk input poin ddi tool georeferensi.

  • Mengatur sebuah nilai kustom tanpa-data untuk sebuah layer.

Mendapatkan data

Pada tutorial ini, kita akan menggunakan citra cantik dari layangan dan balon yang dikumpulkan oleh The Public Laboratory . Mereka membuat gambar versi tergeoreferensi juga tersedia, tapi kita akan mengunduh citra yang belum melewati proses georeferensi dan data unduhan akan melewati proses georeferensi di QGIS. Jika anda menyukai citra yang mereka sediakan , anda dapat explore it pada Google Earth.

Unduh citra JPG Washington Square Park, New York . Anda dapat mengklik kanan tombol JPG dan memilih Save link as....

For convenience, you may directly download a copy of the dataset from the link below:

newyorkcity-washingtonsquarepark.jpg

Prosedur

  1. Untuk tutorial ini, kita akan menggunakan layer OpenStreetMap sebagai referensi layer kita. Install plugin OpenLayer dari Plugins ‣ Manage dan install plugins ‣ Get more . Lihat docs/menggunakan_plugin untuk informasi lebih untuk menggunakan plugins di QGIS.

../_images/1.png
  1. Ketika sudah diinstall, akses Plugins ‣ OpenLayers plugin ‣ Add OpenStreetMap layer . Ini akan menambah sebuah layer dari ubin pixel yang belum terender dari OpenStreetMap data.

../_images/2.png
  1. Sekarang anda memiliki layer OpenStreetMap terbuka di QGIS. Perhatikan CRS untuk layer ini. (CRS) ter-set pada EPSG 3857 Pseudo Mercator. Ini penting untuk diperhatikan, karena koordinat yang kita ambil dari layer ini akan berada di CRS ini.

../_images/3.png
  1. Sekarang tugas anda untuk mencari daerah sekeliling area yang akan kita coba untuk kita lakukan georeferensi. Anda dapat menggunakan Pan dan zoom untuk mencari lokasi area tersebut pada layer OpenStreetMap. Tapi kita dapat mengambil kesempatan ini untuk mendemonstrasikan tool lain mungkin akan membantu anda di masa yang akan datang. Kita tahu bahwa citra yang kita unduh adalah Washington Square Park di New York. Jika anda mencari tempat tersebut, anda akan bisa mencari lokasi halaman wikipedia pada tempat tersebut. Koordinat untuk taman terdaftar di sana,

../_images/4.png
  1. Anda akan melihat bahwa koordinat dalam DMS atau Degrees/Minute/Second dan Garis Lintang dan Garis Bujur. Tetapi karena layer kita dalam proyeksi Mercator, kita akan membutuhkan koordinat Mercator untuk mencari lokasi taman. Di sini dimana sebuah tool command-line yang bernama cs2cs menjadi berguna. Jika anda menginsstall QGIS dari installer OSGEO4W, anda sudah memiliki tool ini pada sistem anda. Pada Linux dan Mac, tool ini sudah masuk dalam kelengkapan QGIS. Luncurkan sebuah jendela terminak dan ketik cs2cs untuk memeriksa apakah ini tersedia. Pengguna Window dapat menemukan sebuah terminal pada Start ‣ OSGeo4W ‣ MSYS.

Catatan

MacOS users can locate the cs2cs tool at /Library/Frameworks/PROJ.Framework/Programs/cs2cs

../_images/5.png
  1. Ketika anda sudah memverifikasi bahwa tool cs2cs ada pada sistem anda, saatnya untuk mengkonversi garis lintang dan bujur menjadi koordinat Mercator. Cara tool ini bekerja adalah anda harus menentukan sebuah CRS source dan destination . Definisi CRS bisa PROJ4 string <http://trac.osgeo.org/proj/wiki/GenParms>`_ atau sebuah EPSG code. Karena kita sudah tahu kode EPSG untuk input dan output keluar dari CRS, kita akan menggunakan ini. Cara paling sederhana untuk menggunakan tool ini adalah dengan mengsuplai koordinat input pada command line. Perhatikan bahwa tool menerima koordinat dengan urutan X Y , jadi kita ingin memasukkan `Longitude Latitude . Masukkan command berikut di terminal dan tekan enter. Lihat bahwa kita perlu untuk keluar dari quotes (”) dengan sebuah backslash (\). Ketika anda tekan enter, anda akan melihat tool untuk memroses koordinat output dan mencetak output koordinat X Y pada EPSG 3857 CRS.

echo "-73d59'51\" 40d43'51\"" | cs2cs +init=EPSG:4326 +to +init=EPSG:3857

-8237364.02 4972720.34 0.00

If the above command does not work for you, please try the following variant

echo -73d59'51 40d43'51 | cs2cs +init=EPSG:4326 +to +init=EPSG:3857
../_images/6.png
  1. Kopi koordinat ini dan pindah ke QGIS. Pada bagian bawah jendela QGIS, anda akan melihat sebuah kotakteks berlabel koordinat. Masukkan koordinat di sana dengan bentuk X, Y. Tekan Enter, anda akan melihat Peta bergeser sedikit, tapi bukan zoom. Untuk menzoom area, pilih skala 1:2500 dari dropdown skala disebelah kotak koordinat dan tekan enter.

../_images/7.png
  1. Voila! anda sekarang lihat area Washington Square Poark pada kanvas anda. Sekarang waktunya untuk memulai georeferensi. Luncurkan Georeferencer dari menuselection:Raster –> Georeferencer –> Georeferencer . Jika anda tidak melihat dari menu item, anda akan perlu mengaktifkan plugin Georeferencer GDAL dari Plugins ‣ Manage and install Plugins ‣ Installed.

../_images/8.png
  1. Pada jendela Georeferencer , akses File ‣ Open raster . Navigasi ke file JPG yang diunduh dan klik Open.

../_images/9.png
  1. Pada Coordinate Reference System Selector , pilih EPSG:3857 Pseudo Mercator

../_images/10.png
  1. Sekarang klik pada tombol Add Point pada toolbar dan pilih sebuah lokasi yang dapat teridentifikasi dengan mudah dari gambar. Sudut-sudut, persimpangan, kutub dan lain-lain. Buatlah control points yang baik.

../_images/11.png
  1. Ketika anda mengklik gambar pada sebuah lokasi poin kontrol, anda akan melihat jendela pop-up bertanya pada anda untuk memasukkan koordinat peta. Klik tombol From map canvas.

../_images/12.png
  1. Temukan lokasi yang sama pada layer referensi anda, seperti OpenStreetMap dan klik di sana. Kordinat terkumpul dengan klik pada kanvas peta. Klik OK. Dengan cara yang sama, pilih sedikitnya 4 poin pada gambar dan tambahkan koordinatnya dari layer referensi.

../_images/13.png
  1. Sekarang akses Settings ‣ Transformation settings.

../_images/14.png
  1. Pilih pengaturan seperti di bawah. Pastikan tombol Load in QGIS when done diberi tanda cek. Kembali ke jendela Georeferencer , akses File ‣ Start georeferencing . Ini akan memulai proses pembengkokan gambar menggunakan GCP dan membuat raster target.

../_images/15.png
  1. Ketika proses selesai, anda akan melihat layer tergeoreferensi terbuka di QGIS. Jika semua berjalan baik, anda akan melihatnya tersusun dengan baik pada layer OpenStreetMap.

../_images/16.png
  1. Untuk membuat output kita terlihat baik, mari hapus nilai tanpa-data yang bewarna hitam dan putih. Klik kanan pada layer gambar dan pilih Properties.

../_images/17.png
  1. Pindah ke tab Transparency . Kita ingin mengindikasikan pixel hitam dan putih mana saja pada gambar yang mana nilai no-data dan harus dibuat transparan. Masukkan 0 sebagai No data value . Juga,pada guilabel:Custom transparency options , klik tombol + dan tambahkan 255 dengan pixel transparan untuk setiap band dan masukkan 100 pada :Percent transparent . Klik OK.

../_images/18.png
  1. Sekarang anda akan melihat gambar tergeoreferensi melapisi layer dasar dengan baik.

../_images/19.png
comments powered by Disqus

This work is licensed under a Creative Commons Attribution 4.0 International License